Nvidia updates boot to flashing cursor

Just updated my own Xfce system with latest Nvidia drivers and boots to flashing cursor. This is two machines now. My own on Xfce with GTX 1060 and another with GTX 1650 on Xfce. On my system i was able to use timeshift with Btrfs and go back. So i updated everything except for the nvidia drivers and is okay.

Edit: nvidia-dkms version 460.56-1 plus other nvidia updates.

Are you using hybrid graphics? Just wondering whether I should hold off on the update…

No both of these are desktops. Mine is Intel CPU with GTX 1060 and the Other is an AMD Ryzen with GTX 1650.

Edit: On mine i blacklisted the nvidia updates after reverting to a previous snapshot. The other one i will try downgrading if i can.

Here nvidia-dkms 460.56-1 is working as expected, no booting problem.

How can that be? I have two systems both same issue? I have both set up as per the wiki for additional configurations.

Edit: I don’t know what the issue is?

I’m using the testing repos now.
I can check with the stable repos soon.

Okay…thanks as i have two systems same. I was advised earlier so i tried my own and got the same flashing cursor. There are like 4 nvidia updates.

The same with the stable repos, working as expected before and after all updates.

Okay so why would that be. My computers have nothing special. I’m not messing with settings or anything. It’s on two of these systems on Xfce.

What’s your DM?

Lightdm … and i have blacklisted these for now. Afraid to try again.

:: Starting full system upgrade...
warning: lib32-nvidia-utils: ignoring package upgrade (460.39-1 => 460.56-1)
warning: nvidia-dkms: ignoring package upgrade (460.39-1 => 460.56-1)
warning: nvidia-utils: ignoring package upgrade (460.39-1 => 460.56-1)
$ pacman -Qs nvidia
local/egl-wayland 1.1.6-1
    EGLStream-based Wayland external platform
local/libvdpau 1.4-1
    Nvidia VDPAU library
local/libxnvctrl 460.39-1
    NVIDIA NV-CONTROL X extension
local/nvidia-dkms 460.56-1
    NVIDIA drivers - module sources
local/nvidia-installer-db 2.4.15-1
    Database for the script to setup nvidia drivers in EndeavourOS
local/nvidia-installer-dkms 3.3.8-3
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-settings 460.39-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 460.56-1
    NVIDIA drivers utilities
local/nvtop 1.1.0-2
    An htop like monitoring tool for NVIDIA GPUs
[ricklinux@eos-xfce ~]$ pacman -Qs nvidia
local/egl-wayland 1.1.6-1
    EGLStream-based Wayland external platform
local/lib32-libvdpau 1.4-1
    Nvidia VDPAU library
local/lib32-nvidia-utils 460.39-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.4-1
    Nvidia VDPAU library
local/libxnvctrl 460.39-1
    NVIDIA NV-CONTROL X extension
local/nvidia-dkms 460.39-1
    NVIDIA drivers - module sources
local/nvidia-installer-db 2.4.15-1
    Database for the script to setup nvidia drivers in EndeavourOS
local/nvidia-installer-dkms 3.3.8-3
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-settings 460.39-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 460.39-1
    NVIDIA drivers utilities
[ricklinux@eos-xfce ~]$ 

Edit:: I have the optional enhancements as per the wiki.

Strange.

I’d try these, one by one:

  • change to sddm
  • reinstall nvidia-dkms, linux and linux-headers

Hope you are brace enough to try… :sweat_smile:

And chrooting helps if nothing else. :wink:

What do i need to change to sddm?

sudo pacman -S sddm
systemctl disable lightdm
systemctl enable sddm
reboot

Okay but i don’t want to stay on sddm? Should i remove the optional enhancements also? If i want o reinstall the drivers do i install sddm first and then try installing the drivers via updates by taking them off the ignore list?

Installing sddm is optional. I’ve just seen on several occasions that changing DM has helped, at least temporarily.

But maybe it is best just to reinstall nvidia driver and linux as mentioned above.
I’m using both DMs successfully on this machine too, on another install.

So first take them off the ignore list and reinstall via terminal?

sudo pacman -S nvidia-dkms linux linux-headers

Yes, remove from ignore list and:

sudo pacman -Syu nvidia-dkms linux linux-headers

and reboot.

Edit: added ‘yu’.