Nvidia-settings configurations not loading after boot

Hi guys,
I’ve been having issues getting my monitors refresh rate to stay after boot. When rebooting the refresh rate is set to 144hz until I log in. After log in, the screen goes black for a second and then the refresh rate is back to 60 and my nvidia-settings configurations have been reset to defaults.

Things I’ve tried doing.
I’ve saved all my configs in
/etc/X11/xorg.conf.d ,
/etc/X11/xorg.conf,
/etc/X11/xinit/xinitrc ,
/etc/X11/xorg.conf.d/20-nvidia.conf.
~/.nvidia-settings-rc

Nothing seems to be making sure my primary monitor is set to 144hz.
Any help or ideas would be appreciated, thanks guys.

Have you tried setting it up using xrandr?

I have tried to do my setup in ARandR but there was no options for refresh rates.

Yes i guess they use arandr on i3?

Yes they do. But I’ve also configured it in xrandr using cli and it worked until I rebooted aswell.

Hopefully someone can give you advice on this. :slightly_smiling_face:

Edit: Is this any help?

https://bbs.archlinux.org/viewtopic.php?id=256663

No luck.

did you saved it as monitor.sh in the directory /home/USERNAME/.screenlayout/?

you can save the file with ARandR (name it as “monitor”) then open it with text editor and add --rate 144

1 Like

Seems like adding –rate 144 to my ~/.screenlayout/layout.sh file and adding exec --no-startup-id ~/.screenlayout/layout.sh in my i3 config has fixed the issue.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.