Nvidia probem after update

Today I got an update that contained a Nvidia update and upon reboot the system no longer will boot into the desktop. How can I fix this problem. I know there is a way to get around the Nvidia driver but can’t remember how to do it.

Hello @cage
Not sure what your hardware is or desktop but you could try logging in to tty and make some changes here. Not sure if it’s failing to load the nvidia or it’s an xorg problem but this issue has been recent on Cinnamon desktop.

It’s a desktop with Nvidia graphic geforce 1050. Problem it will not boot into the desktop environment but hangs after doing the block check. I tried to see if I could fix it using a live ISO but cannot access sda1 even after mounting it manaually.

Machine info? Logs? Error messages?

edit: Also, a more descriptive title would help, should anyone else run into the same problem in the near future and search for it.

But if drive is faulty i would say that the issue is not related to update.

Checked drive with gparted and can access the drive no problem. I tried to remount the drive and it worked. Unfortunately when I try to fix the problem the command to access boot says fstab does not exist. So it looks like I am going to have to reinstall EOS. Now I am trying to figure out how to access the data files on that drive. I don’t know but gparted does have a copy command but not sure if that will solve the problem. Some where along the line something got messed up and is not allowing it to boot into the DE.

The also had this issue with the Nvidia GTX 1650 on Cinnamon again. It’s supposedly booting to a black screen with the latest update today. I will have to look at it. I am wondering if the xorg conf file has been overwritten or something. Tonight after work i will check my own installation on Xfce with my Nvidia GTX 1060. I’m not sure what updates there were but will see.

Edit: Updated my system with the Nvidia GTX 1060 on Xfce and no issues. I will have to look at the other system with Cinnamon that has the Nvidia GTX1650.

Are you sure fstab doesn’t exist?

cat /etc/fstab

According to the mounting command for fstab, it didn’t exist. I just reinstalled EOS without the Nvidia driver, that should end the problems. But yes my system booted into a black screen and not to the XFCE DE. Everything is up and running with only setting my printer back up. Thanks to all for all the suggestions on how to fix this mess.

i just like to add myself to the same problem (coincidentally i have a gtx 1050ti)
update “nvidia-460.39-1” borks my system and wont let me boot properly as well.
i fixed it by downgrading for now to 460.32.03

edit: had to downgrade utils as well or i wasnt able to, gotta downgrade both at the same time

Just a FYI I found that you can copy your data files using Gparted. If you use the recover data function and the drive is not dead, you can copy all your data files to another drive.

i would just like to confirm that the new update of “nvidia-460.39-2” seems to fix the issue
just restarted and all is going well

For me nvidia-460.39-2 seemed to be the problem. Downgrade to nvidia-460.32.03-6-x86_64.pkg.tar.zst (and adding it to IgnorePkg in pacman.conf) fixed the problem for now. I’ll try again with a new version.