"nvidia-installer-check" says my 1080 is not supported

Hmm? This should be correct as far as i know. Everything looks installed correctly so maybe @joekamprad can help here since he is the nvidia guru?

I would leave things as they are for now until we get some other direction because i’m sure it’s installed right. Just something I’m missing here? Looks like what the wiki states but like i say these dual graphics are a bit challenging sometimes.

Edit: Maybe @jonathon has an idea as he knows more than i. :slightly_smiling_face:

I’ll wait until Tuesday, if hybrid is too complicated maybe I just use nvidia proprietary driver only.

The other option is you may have to install straight nvidia with bumblebee and then optimus instead of the dkms version.

Read this post here where user had sort of similar problem.

Sorry, I can’t be more help than this. Should be able to get it working I’m sure. It may just take a little more time and expertise.

the checker script for Nvidia IDS is currently not getting the db files, ther is a change upstream on Nvidia webside i would say, we need first to fix this… installing seem to work also without working check… if not you can also force to do so…

https://forum.endeavouros.com/t/nvidia-installer-update-db-fetchs-the-most-out-dated-branch

It’s working now, The optimus-manager-qt's icon doesn’t show up in my tray so I must switch to Nvidia mode via optimus-manager --switch nvidia command. Now all my application is using Nvida GPU and I can open nvidia-settings . Cheers.

EDIT:
How to make optimus-manager-qt icon appears at tray:

  • Run optimus-manager-qt command

  • Right click tray icon>settings>general

  • Check ‘Launch at startup’

3 Likes

You’re right, Nvidia has changed how they show their Nvidia products.
I’m currently working on it, and hopefully this gets solved in the near future.

5 Likes

i could be with you if you hint me to it or on testing, i still have nvidia card, but ordered AMD one :wink:

4 Likes

Thanks! Like a said i don’t have a lot of experience with these optimus hybrid graphics but i figured it was installed correctly as i didn’t see any error’s in the installation. Knew i was missing something in the mix. Glad it’s working.

Same here, I still have the GEForce GTX 1050 Ti and the GEForce GT 640.

Pudge

1 Like

Please do test it! The more cards are tested, the better. :smile:

So, command nvidia-installer-check needs testing. No parameters needed.

2 Likes

[marcelo@linux ~]$ nvidia-installer-check
grep: /tmp/nvidia.ids: Arquivo ou diretório inexistente
grep: /tmp/nvidia-390xx.ids: Arquivo ou diretório inexistente
Sorry, your Nvidia card (id: 2184) is not supported by nvidia-dkms nor nvidia-390xx-dkms.
[marcelo@linux ~]$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation TU116 [GeForce GTX 1660] (rev a1)

Did you update nvidia-installer-db to the latest version 2.4.7-1 ?

1 Like

Just did.

[marcelo@linux ~]$ sudo pacman -Ss nvidia-installer-db
[sudo] senha para marcelo: 
endeavouros/nvidia-installer-db 2.4.6-1 [instalado]
    Database for the script to setup nvidia drivers in EndeavourOS
[marcelo@linux ~]$ checkupdates
nvidia-installer-db 2.4.6-1 -> 2.4.7-1
reflector 2020.8.19-2 -> 2020.9-1
[marcelo@linux ~]$ nvidia-installer-check
Your graphics card (id: 2184) is supported by the nvidia-dkms driver.
To install a driver for this card, you can use nvidia-installer-dkms.
1 Like

Great! :smile:

1 Like

@manuel
Here are the results for the Nvidia GEForce GTX 1050 Ti

$ nvidia-installer-check
Your graphics card (id: 1c82) is supported by the nvidia-dkms driver.
To install a driver for this card, you can use nvidia-installer-dkms.

I will swap out video cards and report back shortly.

Reporting back.
I am checking this on a computer reserved for testing x86_64 EndeavourOS stuff.
When I fired it up, it needed 167 updates, as most of my testing lately has been on arm.
After updating and getting into BIOS and changing from internal graphics to PCI, I installed the GTX 1050 Ti. As per above the Nvidia GEForce GTX 1050 Ti booted right up and I checked nvidia-installer-check. I never did actually install any Nvidia drivers, as the internal graphics are in the Ryzen 5 3400G.

Then I swapped out to the Nvidia GEForce GT 640. It booted as far as grub, then “starting version 246.4-1-arch” was very blurred. After that complete jibberish.
I swapped this card out for the other GT 640 I had, same results. At this point curiosity got the better of me and I swapped in the GTX 1050 Ti from previously. It booted up perfect.

I am sure both video cards worked last time I tested nvidia-installer-dkms, but obviously that was 167 updates previous. My guess is either Nvidia or something in the newest kernel isn’t supporting the GT 640 anymore.

I hope that helped at least a little.

OT
I have an AMD RADEON rx560 video card that works perfect in Windows, but not with Linux. Since we are now up to kernel 5.8.x this would be a good chance to check this out while the test computer is hooked up.

Pudge

2 Likes

is this not one moved to legacy shortly? so need the 340 drivers?

According to the Nvidia web site, the latest driver for this card is
Driver Version: 450.66 - Release Date: Tue Aug 18, 2020

Archlinux repo says it has
450-66-17

Pudge

I wanted to forget about this, but I just could not do it.
This refreshed my memory of why I am trying to get rid of anything Nvidia.
When I started, this was a AMD motherboard with AMD graphics built in the Ryzen 5 3400G.
So the only video driver was amdgpu.
I plugged in the GTX 1050 Ti and it didn’t care, it booted up and I installed nvidia-installer-dkms to obtain nvidia-installer-check, which also worked fine. No Nvidia drivers were installed in alll of this. The 1050 Ti must have been running on the kernel module, what’s it called - mode-something.

Then I put in the GT 640 and it wouldn’t even boot up period.
Started thinking (look out world) that maybe it couldn’t run on the kernel module like the GTX 1050 did. So I took the GT 640 out, booted up on the built in graphics, and installed xf86-video-nouveau figuring The GT640 could run on that. Nope, still would not boot.

I then re-installed the GTX 1050 Ti which worked fine with nouveau and amdgpu, and actually used nvidia-installer-dkms to install the nvidia drivers.

Put the GT 640 back in, booted up and ran great when the nvidia drivers were pre-installed.

TaDa

the results of nvidia-installer-check on the Nivida GEForce GT 640:
$ nvidia-installer-check
Your graphics card (id: 1282) is supported by the nvidia-dkms driver.
To install a driver for this card, you can use nvidia-installer-dkms.

If I remember correctly, I have used the ISO to install EndeavourOS with the GT 640 using the with Nvidia graphics line on the ISO grub screen. Then check the install Nvidia drivers section of choosing your DE, etc.

Next up. Gather up all my Nvidia cards and take them to the recycling place. Well all except one GTX 1050 Ti which I need for the Ryzen 7 2700 which does not have built in graphics. That is why I bought the the AMD RADEON rx560 video card, to replace this GTX 1050 TI. But alas I haven’t gotten that to work, so I’m stuck with one Nvidia card.

Sorry for the Nvidia rant. A lot of people like Nvidia video cards, I used to be one of them, but not anymore.

Pudge

3 Likes