Nvidia-inst urls not working "again"?

Hello everyone,

I am trying to install my Nvidia drivers using Nvidia-inst instead of the other methods but I’m getting the “nvidia-driver-supported-branches could not fetch card ids from Nvidia” error.

Found similar posts from 2023 mentioning wrong urls but with no useful solutions. I ran pacman -Syu which showed that everything is up to date. I have a RTX 3070 which should be supported to my knowledge but maybe I’m just wrong.

Does someone know what is going on here? Thanks in advance!

This app fetches the info from the Nvidia site, which is sometimes changing so that the app cannot read it. I just tested the app and it seems to work now.

But (in principal) your GPU definitely should be supported by the latest (550 series) driver from the Arch packages, although there have been reports that this driver causes problems for some cards.

If you still have this problem with the app, please run the following command and show the output here:

device-info --nvidia-gpuid

Still not working, it shows the same error. Running

device-info --nvidia-gpuid

only shows: 2488

This is what I get from nvidia-driver-supported-branches with your card id:

$ nvidia-driver-supported-branches 2488
NVIDIA card id: 2488
Fetching driver data from nvidia.com ...

Series 550: supported (nvidia.com: 550.78)

It means your card is basically supported by the latest Nvidia driver (nvidia-dkms version 550.78-1) provided by the Arch repos.

So you should be able to install packages

  • nvidia-dkms
  • nvidia-utils
  • nvidia-settings

and add kernel parameter

  • nvidia-drm.modeset=1

Did you try running a test command

nvidia-inst --test

It should show you the commands needed to install the Nvidia GPU driver.

Use command nvidia-inst --help to see some info about the options.

I did try running the test command. Today I tried it again, with the following result:

$ nvidia-inst --test
2024-05-30 15:06:56: Info: Running: nvidia-inst v24-1
2024-05-30 15:06:56: Info: Command line: nvidia-inst --test
2024-05-30 15:06:56: Info: Selected mode: nvidia
NVIDIA card id: 2488
Fetching driver data from nvidia.com ...
nvidia-driver-supported-branches: error: Nvidia id data not available from 'https://download.nvidia.com/XFree86/Linux-x86_64/550.78/README/supportedchips.html'! Curl exit code 7.
2024-05-30 15:06:57: Error: nvidia-driver-supported-branches could not fetch card ids from Nvidia.

Strange. Here nvidia-inst --test works without any problem.

Could be some VPN or other network related issue?

Well, I feel dumb. You where absolutely right about a network related issue: a Pihole was blocking the request.

I can’t believe that I missed that. It does run now, showing a dependency satisfaction error.

Thanks for your help and time, and pointing out the obvious!

1 Like

Great that you found the issue! :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.