NVIDIA GTX 1050 with mainline kernel not booting but booting with LTS(kinda long post sorry)

I was trying to resolve the issue of installing NVIDIA drivers on a fresh EndeavourOS install. after installing EndeavourOS the OS was not booting at all (it went to the GUI grub menu but always rebooting from there). I tried to install the OS for a second time but this time I selected the LTS kernel, it then booted up fine, then I tried to doing nvidia-isnt the drivers seem to install fine according to the terminal but after restarting and doing inxi -Ga the driver was never installed. If I switch from the LTS headers and LTS kernal to the mainline and stable kernel my system does not boot. I know I never encountered an issue like this on the previous version as I had been running that version for 1.5 years but this issue stumped me so hard that I installed windows again which hurts on another level. This was my topic on attemting to solve the driver issue Inxi -G result for Nvidia driver as N/A

I do not think this is a Bug with the installer or nvidia-inst… must be something around packages… or hardware

and why creating a new post for this anyway?


1 Like