Nvidia driver update issue

Nvidia 425.67 drivers just updated and when rebooting desktop wouldn’t load. Tried rebooting again and was the same. I did ctrl alt f2 and logged in as root. Ran mkinitcpio -P and then systemctl reboot. My setup has all the enahancements done on it and still get this problem. So this was my easy fix.

[ricklinux@eos-xfce ~]$ inxi -Ga
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: nvidia 
           v: 465.27 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1b83 
           class-ID: 0300 
           Display: x11 server: X.Org 1.20.11 driver: loaded: nvidia display-ID: :0.0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3") 
           s-diag: 583mm (23") 
           Monitor-1: DVI-D-0 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6") 
           diag: 547mm (21.5") 
           OpenGL: renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 465.27 
           direct render: Yes 
[ricklinux@eos-xfce ~]$ 

Fixed with running mkinitcpio -P after logging in to TTY as root.

3 Likes

Thanks, this solved for me, a simple fix, only if you know the command to type! :slight_smile:

nvidia or nvidia-dkms package in use?

any time we get update nvidia version ( and nvidia-dkms) , we need a version kernel ,
there is this error ( drm nvidia version do not matche with kernel , → not running , access denied)
ok with

sudo mkinitcpio -P

Simple, create this hook in /etc/pacman.d/hooks/nvidia.hook, so that mkinitcpio will be triggered each time there is a nvidia-dkms update. You can replace Target=nvidia-dkms with Targer=nvidia if needed.

[Trigger]
Operation=Install
Operation=Upgrade
Operation=Remove
Type=Package
Target=nvidia-dkms
[Action]
Depends=mkinitcpio
When=PostTransaction
Exec=/bin/sh -c ‘/usr/bin/mkinitcpio -P’

2 Likes

nvidia-dkms for me and i have all the enhancements set. This time it happened again and booted to starting … version xxx and didn’t go any further. So i just ran mkinitcpio -P from a TTY and rebooted and it worked. I was wondering why the dkms version didn’t rebuild correctly again. Sometimes there is no problem and other times it happens to me also even with the enhancements. Does it need an Nvidia hook? I’m sure those without enhancements will most likely run into issues also. Maybe?

Edit: I am going to try the hook as @pap33 has written above. This should finally alleviate this issue. :crossed_fingers:

we could have this as a package to install, but i do just add it to wiki for now:

1 Like

I didn’t have a hooks directory, so I created it and also the file. :laughing:

Thank you

I updated here, and no problems.
I’m only using the ‘logind-check-graphical=true’ option inside the lightdm.conf

[marcelo@eos ~]$ inxi -Ga
Graphics:  Device-1: NVIDIA TU116 [GeForce GTX 1660] vendor: Gigabyte driver: nvidia v: 465.27 
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2184 class-ID: 0300 
           Display: x11 server: X.org 1.20.11 driver: loaded: nvidia 
           resolution: <missing: xdpyinfo> 
           OpenGL: renderer: NVIDIA GeForce GTX 1660/PCIe/SSE2 v: 4.6.0 NVIDIA 465.27 
           direct render: Yes 
[marcelo@eos ~]$ 

I’m glad you had no problem and usually i don’t either but it seems it’s been just random. So i have created the hook also along with the enhancements because i have watched this happen a number of times to others along with myself and it seems that for what ever reason i have had to run mkinitcpio -P a number of times when having this issue so it makes sense that i try the hook. Hopefully this puts an end to the Nvidia driver saga! :grinning_face_with_smiling_eyes:

1 Like

That`s very optimistic haha

1 Like

@SimonJ
Just gotta have faith. Anythings possible!

2 Likes

@ricklinux and others:

Has this nvidia issue happened only with

  • nvidia-dkms

or also on these:

  • nvidia
  • nvidia-lts

?

If we create a pacman hook for this, it would be essential to know which nvidia packages can cause this issue.

yay -Si nvidia
Repository      : extra
Name            : nvidia
Version         : 465.27-2
Description     : NVIDIA drivers for linux
Architecture    : x86_64
URL             : https://www.nvidia.com/
Licenses        : custom
Groups          : None
Provides        : NVIDIA-MODULE
Depends On      : linux  nvidia-utils=465.27  libglvnd
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 23,40 MiB
Installed Size  : 23,40 MiB
Packager        : Sven-Hendrik Haase <svenstaro@gmail.com>
Build Date      : jue 29 abr 2021 23:24:17
Validated By    : MD5 Sum  SHA-256 Sum  Signature
1 Like

So you have had the issue with package nvidia?

pacman -Q nvidia

Yes I had the problem yesterday.

pacman -Q nvidia
nvidia 465.27-2
1 Like

OK, thanks for the report. :smile:

Hi all!

We are now adding a new package nvidia-hook that runs mkinitcpio -P when nvidia driver is updated/installed/removed.
The package is already available on some mirrors, and will soon come to all mirrors.

Please try it and report. Hope it will fix this problem.

But if it creates any new issues, please let us know as soon as possible! :sweat_smile:

3 Likes

For me it has been on nvidia-dkms

Edit:
I added a hook that was provided by @pap33 to try it? Won’t know if this works until we have more updates.

Edit: I guess i will remove it if there is one being added. How is it placed? Same location or added somewhere else?