Nvidia driver screen blinks

Tyyy. Everything’s working fine. I just had to install lib32-nvidia-utils before installing it, so that I could install steam afterwards.

And how did you add these packages to the exception? I added “#IgnorePkg = linux linux-headers nvidia-dkms nvidia-utils lib32-nvidia-utils” to /etc/pacman.conf, but I am still prompted to update these packages

Remove the initial # character on that IgnorePkg line. :wink:

Seriously, ignoring updates of essential packages like kernel and GPU driver can be only a short time workaround since there will be other issues later on.

Thank you. It’s temporary. Until nvidia fixes the problem.

2 Likes

i’ve been thinking of temporally unistalling my gtx 1650 to buy-install a Sapphire Pulse RX 6400 instead

And why did you downgrade the kernel version? The driver’s minimum system requirements state that you can use kernel version 3.10 or newer

i just tried driver 530 with latest linux kernel yesterday and it would not boot into the desktop

If I knew I was going to use linux as my main system, I would have bought a Radeon RX 5700 instead of the 2060 super :sweat_smile:

i just wish i could downgrade to nvidia 525 but then it wont boot to my desktop, does anyone knows if it’s possible to downgrade to nvidia 525 ? unfornatelly latest drivers still gives flickering on my desktop

I’m not sure if you can downgrade this way? Not sure also if you have nvidia-settings installed?

sudo downgrade nvidia nvidia-utils

i have all these installed

Ok i managed to get nvidia 525 drivers to work, i had to downgrade linux and linux-headers to 6.2.13, nvidia drivers → 525.89.02-2
Source:
https://www.reddit.com/r/linux_gaming/comments/16brazv/how_do_i_downgrade_to_either_nvidia_driver/

You should have been able to do it in all one command?

sudo downgrade nvidia nvidia-utils nvidia-settings

Edit: Sorry i made an error which i corrected.

yes i guess that might be the best way, problem is i didnt know the correct linux kernel to work with that driver

As long as you know the version number and then select it.

Edit: It would do each one at a time.

yes this was the command i used

 sudo downgrade linux linux-headers nvidia-dkms nvidia-utils 

i like to use the mouse click to select the packages to downgrade, i find easier that way

I didn’t realize you were using dkms as you posted here 22 days later. It would be much better if you had created a topic for your specific issue so as to provide that info. But hopefully you have it working.

i updated the nvidia drivers and kernel to latest today, i had nvidia 530.41.03-1 and kernel 6.3.9 installed and i was seeing a red text on boot saying it failed to load the kernel modules, guess i’ll just get an amd gpu rather than waiting for nvidia to fix the issue

Looks like there’s finally a fix for the flicker issue

i hope it’s available to install soon, just took a look on extra-testing
https://archlinux.org/packages/extra-testing/x86_64/nvidia/

Edit: i might just try this package and see if it solves the issue on my end:
https://aur.archlinux.org/packages/nvidia-beta-dkms

2 Likes

i installed nvidia-beta-dkms and for some reason it made my plasma desktop slow and slugish, so i installed nvidia package back, i’ll wait nvidia 545.23.06-1 to hit the official repos