Nvidia Driver Not Loading and Second Monitor Issues

Hello everyone, I need some help from you smart folk because Nvidia seems to hate me in particular.

I updated my system last night, which included a update to nvidia-dkms, nvidia-utils, linux-zen and linux-zen-headers, and my second monitor started lagging like crazy, similar to what I described in this thread. So I tried the same solution as I did in that thread: downgrade the drivers. So I did, and I downgraded them to version 525. Unfortunately that caused more issues, since it seemed to unload the driver. Output of modprobe:

$ modprobe nvidia -vv

modprobe: INFO: custom logging function 0x55ac4b27aaf0 registered
modprobe: FATAL: Module nvidia not found in directory /lib/modules/6.3.1-zen1-1-zen

So after that I upgraded the drivers again, same issue as before: laggy monitor. So I downgraded drivers and kernel, and it unloaded. So I upgraded and drivers are still unloaded. I do not know why. Something else I guess should be noted is that I was installing the drivers directly through pacman, installing the packages nvidia-dkms and nvidia-utils. Details will be in the logs I have collected to try to figure out what’s going on. Reading things like dmesg and lspci does prove more and more that the drivers aren’t loaded, but with no explanation as to why.

As always, any and all help is greatly appreciated. I would hope that something can be done to fix this. Anyways, thanks again.

xrandr --verbose latest
pre-update xrandr
inxi log
lspci log
dmesg log
relavent pkglog
OpenGL (EGL)

Other important information:
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.105.0
Qt Version: 5.15.9
Kernel Version: 6.3.1-zen1-1-zen (64 bit)
Graphics Platform: X11

The log part from dkms build/install is missing.

Have you tested other kernels? Do they all fail?

Well I just ran dkms autoinstall, and you can see the output here. What is interesting is that it yelled at me for a lack of a dkms.conf file for the nvidia drivers for version 525. Which is weird because I don’t have the nvidia-dkms 525.78.01 installed, as seen by pacman:

# pacman -Q nvidia-dkms nvidia-utils
nvidia-dkms 530.41.03-1
nvidia-utils 530.41.03-1

So I’m guessing that’s the reason why the drivers aren’t loading? I’m not sure why that is or what I can do about it though.

I have not yet tested other kernels, but I can do that today. I wasn’t able to get dkms to make the drivers for the only other kernel i have installed, which is the base linux kernel. I’m not sure why but I’ll post the command output anyways:

# dkms autoinstall -k 6.3.1.arch1-1
Error! Could not locate dkms.conf file.
File: /var/lib/dkms/nvidia/525.78.01/source/dkms.conf does not exist.
Error! Your kernel headers for kernel 6.3.1.arch1-1 cannot be found at /usr/lib/modules/6.3.1.arch1-1/build or /usr/lib/modules/6.3.1.arch1-1/source.
Please install the linux-headers-6.3.1.arch1-1 package or use the --kernelsourcedir option to tell DKMS where it's located.
Error! Your kernel headers for kernel 6.3.1.arch1-1 cannot be found at /usr/lib/modules/6.3.1.arch1-1/build or /usr/lib/modules/6.3.1.arch1-1/source.
Please install the linux-headers-6.3.1.arch1-1 package or use the --kernelsourcedir option to tell DKMS where it's located.
dkms autoinstall on 6.3.1.arch1-1/x86_64 failed for hid-xpadneo-v0.9-131(1) hid-xpadneo(1)
Error! One or more modules failed to install during autoinstall.
Refer to previous errors for more information

It does give the same error for no dkms.conf file so I guess I will have to look into that.

Yes, the 525 series drivers cannot compile with the linux kernel 6.3 releases. The 530 nvidia drivers are slow and buggy across the board. For now, I’m refusing to upgrade the kernel to 6.3 and sticking with the 525 series drivers.

It’s quite a mess. Thanks, nVidia.

Great, so its not just me. That’s wonderful. The 525 series drivers were not loading, even when I downgraded kernel versions. Dunno how nor why. Would have to go back to downgrading all the things which has proven to not fix things at this point. Maybe I just wasn’t loading the right kernel version? I don’t know.

Regardless, this just goes to show why you don’t update critical systems during a critical time frame, like it is for me right now being the week before finals. Thanks nVidia.

You should be able to get the nvidia drivers to work again. Downgrading them ought to trigger the dkms rebuild. Just downgrading the kernel was not enough it left the 530 drivers in place.

Essentially I used downgrade to roll the kernel back to 6.2.13-arch1 with:

downgrade linux linux-headers linux-api-headers

(for linux-api-headers, I went with version 6.1.9-1: there was no 6.2.13-arch1 version)

To downgrade the nvidia drivers, I used the same process reported here: Second Monitor Lags After Update - #3 by Nfox18212

Just to follow up on this. This might actually be better now with the combination of nVidia drivers 525.116 and the linux kernel 6.3.3. I speculatively installed 525.116 rather than 530.04 and allowed the kernel 6.3.3 update on. DKMS didn’t complain and I have the second monitor up and running with no lag.

Interesting, I’ll have to try this myself. To clarify you upgraded to the 6.3.3 kernel and are running the nvidia 525.116 driver versions, and dkms compiled them?

I first of all installed the nvidia dkms 525.116 to replace nvidia dkms 525.89 under the linux 6.2.something kernel I had running. All looked good so then I installed the linux 6.3.3 kernel as a test and it came up just fine.

I don’t see a package version listed just as 525.116, are you implying you are using nvidia-dkms 525.60.11 6 because that’s the closest version downgrade has listed for me

aur/nvidia-525xx-dkms 525.116.04-1

welp i just installed those same exact drivers through the aur, they compiled and installed on the 6.3.3 kernel, and my second monitor is functional. Unfortunately, I’m getting MASSIVE screen tearing on my second monitor, but oddly only on my second monitor. And only on X11, Wayland technically works better for not having any screentearing but some applications do not like it and will not work. So if you have any tips on getting rid of the screen tearing, please let me know.

Honestly, no idea. I don’t think I did anything special there.

Well that’s lovely. Are you by chance running on a desktop with a dedicated nvidia gpu or are you running a hybrid graphics laptop, because as i’ve discovered hybrid graphics laptops have less options in the nvidia control panel. Oh well, since I technically have a working external monitor I might just make another post about screen tearing. This is why I hate nVidia.

I’m running a Legion 5 Pro with a 5800H and an RTX 3070, in hybrid mode. It looks like this forum doesn’t support the easy upload of config files to provide a reference, sadly. I really don’t think I did very much, if anything, to make a difference here.

Well after updating to nvidia-dkms/nvidia-utils 530.41.03-1 and running this command found on the arch wiki, there’s no more screen tearing, so cool I guess? Just had to wait it out because this command did not work before? I dunno. Either way guess I’ll mark this as a solution, even if its not exactly a solution.

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.