Nvidia desktop orientation problem

I installed nvidia drivers using nvidia-installer-dkms without issue.
I then chose to enable ‘Force Full Composition Pipeline’ in nvidia-settings.
As root I save the config to /etc/X11/xorg.conf.
After a reboot my display was inverted in both x and y orientations…a first for me :laughing:
I was able to restore a sane display by deleting xorg.conf.

Any ideas on this most welcome.

EDIT: NVIDIA GeForce GTX 1050 Ti / NVIDIA Driver Version: 515.43.04

Are you able to change the orientation with settings or xrandr ?

I was able to temporarily restore correct orientation with ‘xrandr -o normal’ for the current session. The fix was to delete xorg.conf.
It would be good to be able to set a xorg.conf without this outcome…

Did you try adding this to /etc/X11/xorg.conf.d/20-nvidia.conf

Section "Device"
    Identifier "Nvidia Card"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"

Section "Screen"
        Identifier      "nvidia"
        Option         "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
        Option          "TripleBuffer"                  "on"
        Option          "AllowIndirectGLXProtocol"      "off"

Edit: https://discovery.endeavouros.com/nvidia/nvidia-optional-enhancements-and-troubleshooting/2021/03/

Edited for error

@ricklinux That worked perfectly. Thanks.

1 Like