Nvidia 555 beta install issue

Hello, got an issue after installing 555 beta Nvidia drivers.
Used this thread. Successfully installed them:

roman@laptop ~> pacman -Qs nvidia
local/egl-wayland 2:1.1.13-2
    EGLStream-based Wayland external platform
local/envycontrol 3.4.0-1
    CLI tool for Nvidia Optimus graphics mode switching on Linux
local/lib32-libvdpau 1.5-2
    Nvidia VDPAU library
local/lib32-nvidia-utils-beta 555.52.04-1
    NVIDIA drivers utilities (32-bit, beta version)
local/lib32-opencl-nvidia-beta 555.52.04-1
    OpenCL implemention for NVIDIA (32-bit, beta version)
local/libvdpau 1.5-2
    Nvidia VDPAU library
local/libxnvctrl 550.78-1
    NVIDIA NV-CONTROL X extension
local/nvidia-beta 555.52.04-1
    NVIDIA drivers for Arch official linux package (beta version)
local/nvidia-hook 1.5-2
    pacman hook for nvidia
local/nvidia-inst 24-1
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-settings-beta 555.52.04-2
    Tool for configuring the NVIDIA graphics driver (beta version)
local/nvidia-utils-beta 555.52.04-2
    NVIDIA drivers utilities (beta version)
local/opencl-nvidia-beta 555.52.04-2
    OpenCL implemention for NVIDIA (beta version)

But nvidia-smi can’t see it:

roman@laptop ~> nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Thank you!

You probably need nvidia-utils-beta

yay -Ss nvidia-utils

aur/lib32-nvidia-utils-beta 555.52.04-1 (+146 1.13) 
    NVIDIA drivers utilities (32-bit, beta version)
aur/nvidia-utils-beta 555.52.04-2 (+341 1.90) 
    NVIDIA drivers utilities (beta version)

Run this in a terminal.

yay -S nvidia-utils-beta lib32-nvidia-utils-beta nvidia-settings-beta

The idea is that you need all the beta packages to replace the ones you had before.

could be an issue? its a dependency of nvidia-settings

Nah, seems like i have them:

roman@laptop ~> pacman -Qs nvidia-utils
local/lib32-nvidia-utils-beta 555.52.04-1
    NVIDIA drivers utilities (32-bit, beta version)
local/nvidia-utils-beta 555.52.04-2
    NVIDIA drivers utilities (beta version)

Removed it and rebooted. Didn’t help(

roman@laptop ~> pacman -Qs nvidia
local/egl-wayland 2:1.1.13-2
    EGLStream-based Wayland external platform
local/envycontrol 3.4.0-1
    CLI tool for Nvidia Optimus graphics mode switching on Linux
local/lib32-libvdpau 1.5-2
    Nvidia VDPAU library
local/lib32-nvidia-utils-beta 555.52.04-1
    NVIDIA drivers utilities (32-bit, beta version)
local/lib32-opencl-nvidia-beta 555.52.04-1
    OpenCL implemention for NVIDIA (32-bit, beta version)
local/libvdpau 1.5-2
    Nvidia VDPAU library
local/nvidia-beta 555.52.04-1
    NVIDIA drivers for Arch's official 'linux' package (beta version)
local/nvidia-hook 1.5-2
    pacman hook for nvidia
local/nvidia-inst 24-1
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-settings-beta 555.52.04-2
    Tool for configuring the NVIDIA graphics driver (beta version)
local/nvidia-utils-beta 555.52.04-2
    NVIDIA drivers utilities (beta version)
local/opencl-nvidia-beta 555.52.04-2
    OpenCL implemention for NVIDIA (beta version)

you have rebuilded initramfs images?

Hm, I think I didn’t. Currently reinstalling all over again, so it should rebuild them.

sudo reinstall-kernels for systemd-boot installs and sudo dracut-rebuildin case of grub bootloader

Yeah, it rebuilded initframes:

:: Processing package changes...
(1/1) reinstalling nvidia-utils-beta                                  [--------------------------------------] 100%
If you run into trouble with CUDA not being available, run nvidia-modprobe first.
:: Running post-transaction hooks...
(1/7) Creating system user accounts...
(2/7) Reloading system manager configuration...
(3/7) Reloading device manager configuration...
(4/7) Arming ConditionNeedsUpdate...
(5/7) Running kernel-install...
Running kernel-install for 6.9.1-2-cachyos-bore
dracut[I]: Executing: /usr/bin/dracut --no-hostonly --force /efi/132656f228044628ac707eea86e04d8d/6.9.1-2-cachyos-bore/initrd-fallback 6.9.1-2-cachyos-bore
dracut[E]: Module 'systemd-pcrphase' depends on 'tpm2-tss', which can't be installed
dracut[I]: *** Including module: systemd ***
dracut[I]: *** Including module: systemd-ask-password ***
dracut[I]: *** Including module: systemd-initrd ***
...
dracut[I]: *** Constructing GenuineIntel.bin ***
dracut[I]: *** Store current command line parameters ***
dracut[I]: *** Stripping files ***
dracut[I]: *** Stripping files done ***
dracut[I]: *** Creating image file '/efi/132656f228044628ac707eea86e04d8d/6.9.1-2-cachyos-bore/initrd-fallback' ***
dracut[I]: *** Creating initramfs image file '/efi/132656f228044628ac707eea86e04d8d/6.9.1-2-cachyos-bore/initrd-fallback' done ***
dracut[I]: Executing: /usr/bin/dracut --hostonly --no-hostonly-cmdline -f /efi/132656f228044628ac707eea86e04d8d/6.9.1-2-cachyos-bore/initrd 6.9.1-2-cachyos-bore
dracut[E]: Module 'systemd-pcrphase' depends on 'tpm2-tss', which can't be installed
dracut[E]: Module 'systemd-pcrphase' depends on 'tpm2-tss', which can't be installed
dracut[I]: *** Including module: systemd ***
dracut[I]: *** Including module: systemd-ask-password ***
dracut[I]: *** Including module: systemd-initrd ***
dracut[I]: *** Including module: systemd-journald ***
dracut[I]: *** Including module: systemd-modules-load ***
...
dracut[I]: *** Constructing GenuineIntel.bin ***
dracut[I]: *** Store current command line parameters ***
dracut[I]: *** Stripping files ***
dracut[I]: *** Stripping files done ***
dracut[I]: *** Creating image file '/efi/132656f228044628ac707eea86e04d8d/6.9.4-arch1-1/initrd-fallback' ***
dracut[I]: *** Creating initramfs image file '/efi/132656f228044628ac707eea86e04d8d/6.9.4-arch1-1/initrd-fallback' done ***
dracut[I]: Executing: /usr/bin/dracut --hostonly --no-hostonly-cmdline -f /efi/132656f228044628ac707eea86e04d8d/6.9.4-arch1-1/initrd 6.9.4-arch1-1
dracut[E]: Module 'systemd-pcrphase' depends on 'tpm2-tss', which can't be installed
dracut[E]: Module 'systemd-pcrphase' depends on 'tpm2-tss', which can't be installed
dracut[I]: *** Including module: systemd ***
dracut[I]: *** Including module: systemd-ask-password ***
dracut[I]: *** Including module: systemd-initrd ***

thats not arch default Kernel you are running ?

local/nvidia-beta 555.52.04-1
    NVIDIA drivers for Arch's official 'linux' package (beta version)

you will need the dkms version

https://aur.archlinux.org/packages/nvidia-beta-dkms

3 Likes

So for beta drivers i should run default kernel? I’ll try to boot from it.

Ooh

   NVIDIA drivers for Arch's official 'linux' package (beta version)

it says that in the info of the package already…

Yeah, i thought it would work if i have it installed. Thanks man

1 Like

little things…

have fun playing beta Games :wink:

1 Like

I looked at this https://www.youtube.com/watch?v=40QI1-4Nlx4

And found this:

And used to install nvidia beta:

git clone https://github.com/Frogging-Family/nvidia-all.git
cd nvidia-all
makepkg -si

I’m planning to go back to regular arch nvidia-dkms after it is released on around June18 (Plasma released it this day, so maybe nvidia will too).

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.