Nvidia 525.85.05-1 update problem

Just did the Nvidia-525.85.05-1 update this morning—rebooted to commandline. Looks like there is a problem with this one-reverted to 525.78.01-1 & everything came back. Just a “Heads-up”.

Have not seen any other reports on this yet. Running current Gnome & system is current.

GDM would not start–could find any screens.

There is this one too:

Ah…I had not seen that one…I’ll keep an eye on things today & hopefully there will be another update to fix this.

1 Like

hmm you may have one of the 4 not fitting?

  1. nvidia
  2. nvidia-utils
  3. linux
  4. linux-headers
    Because nvidia packages are kernel-related and only work when running with the kernel they are built on if not using nvidia-dkms package …
1 Like

so seems also happen when using nvidia-dkms

I have all of those…nvidia has been solid for me for months until this update this morning. I used downgrade to go back to 525.78.01-1 to get back to normal. Downgraded nvidia-dkms, nvidia-settings & nvidia-utils.

I’m currently running nvidia 525.85.05-1 without issues. GeForce 1030.

What DE are you using? I saw this happen with Gnome…

I never had a problem with it on my Nvidia GTX 1060 dual boot Xfce & Win 11.

OK—so this looks like a problem with the update & GDM/Gnome…GDM won’t even start --just shows a blinking cursor in the upper left corner. I can get into a commandline season the usual way & work the “usual” way–no GUI session…Again, as soon as I downgraded–GDM started normally & I was in a Gnome session.

I’m currently running nvidia 525.85.05-1 without issues on bspwm. With nvidia settings, etc. NVIDIA GeForce GTX 1660 Ti.

I’m guessing we have the same problem. However, I am using I3wm and not gnome so if we have the same problem it shouldn’t be related to gnome.

These are the only gnome-related packages I have installed:

~ ❯ pacman -Qe | grep gnome
gnome-keyring 1:42.1-2
polkit-gnome 0.105-9

This is how it freezes for me after updating (win + f2 gets me to commandline):

Castle, which nvidia packages do you have installed? If you run pacman -Qe | grep nvidia do you get these 4 packages?

~ ❯ pacman -Qe | grep nvidia
lib32-nvidia-utils 525.78.01-1
nvidia-dkms 525.78.01-1
nvidia-settings 525.78.01-1
nvidia-utils 525.78.01-1
1 Like

you should be able to downgrade the 3 nvidia packages to get x back: sudo downgrade nvidia-dkms nvidia-utils nvidia-settings
and in the dialogue make sure to use 525.78.01-1 from the selection … if you do not have internet connection choose in addition you can take the local present ones marked as local…

Yes–that worked for me…I also included lib32-nvidia-utils & libxnvctrl to make everything 525.78.01-1

1 Like

yes every package that is involved…

I’m starting to look through the logs…I’ve seen some gnome-keyring errors in my system…that “may” be the tie-in…

$ pacman -Qe |grep nvidia
nvidia-dkms 525.85.05-1
nvidia-hook 1.2-1
nvidia-inst 1.9-1
nvidia-settings 525.85.05-1

1 Like

Is your system dracut or mkinitcpio? All working here:

  5 extra/egl-wayland 2:1.1.11-2 [0B 85.28KiB] [Installed]
  7 extra/libvdpau 1.5-1 [0B 288.03KiB] [Installed]
  8 extra/libxnvctrl 525.85.05-1 [0B 455.63KiB] [Installed]
  9 extra/nvidia-dkms 525.85.05-1 [0B 68.70MiB] [Installed]
 14 extra/nvidia-settings 525.85.05-1 [0B 1.62MiB] [Installed]
 15 extra/nvidia-utils 525.85.05-1 [0B 652.27MiB] [Installed]
 31 multilib/lib32-nvidia-utils 525.85.05-1 [0B 164.66MiB] [Installed]

I’m mkinitcpio…have not wanted to try dracut yet.