NUC Install

Hi all,
I was previously running endeavour on an old iMac and it was running great but my wife has claimed it for her WFH setup (re-installed macOS) anyway tomorrow I should be receiving a shiny new NUC tomorrow.

Just wondering if there are any watch-outs or anything I should be aware of with NUCs or any tips?

Hoping it is fairly straight forward (as much as these things can be), wish me luck.

1 Like

Installing any Linux distro on a NUC is a very straightforward thing, once you have set up your hardware. It is a regular PC with a 86-64 CPU in the end, only in a small form factor.
The only “adventurous” thing about it would be the assembly of the components, so have fun with building it :partying_face: :wink:


Welcome to :enos: forums.

1 Like

I was hoping as much, no nvidia so that helps as well

1 Like

As long as it isn’t one of the NUCs with hybrid nvidia graphics it should be pretty straightforward since it is is all intel.

No nvidia, while I didn’t have too many issues with the iMac hardware (runs nvidia), I was wanting to run wayland reliably on this one…

I don’t have a lot of experience with bios (macs are uefi ), I don’t think I have to do much there outside of changing the boot order so I don’t think I’ll have issues there from what I’ve read

1 Like

Thank you

The NUC should also be UEFI

Ah ok nice, one of the articles I read was referring to changing the boot order in bios, maybe it was outdated?

It’s a pretty current model

It probably supports both legacy/bios and UEFI but in 2021 I would definitely use UEFI.

1 Like

Cool thanks, from what I gather I hit F10 select the drive and away we go.

I have a NUC7 and I had two big issues. I don’t know if this affects newer Intel NUCs but here are the two that sent me near-crazy until I figured them out.

  1. With Linux 5.4 plus, the graphics go mad with the screen tearing and breaking up unless I add i915 to the Modules in /etc/mkinitcpio.conf.
  2. My NUC would not wake from sleep. I had to add snd_hda_codec_hdmi.enable_silent_stream=0 to the end of the linux options in /boot/loader/entries/arch.conf if you install the systemd bootloader or add it to the linux line in /boot/default/grub if you use the grub bootloader (which Endeavouros does).
    I hope you won’t need these and other people might have better solutions. Best of luck.
1 Like

Saved, thanks

NUC8i7HVK user here. With some NUC models you may need to faff with the fan controls in the motherboard firmware to stop the fan from driving you insane. The only other thing I found was that the HDMI ports were somewhat buggy, e.g. monitors not going to sleep or waking from sleep for no apparent reason. Everything worked as expected when using displayport. However, I haven’t tried this for a while so maybe someone fixed whatever bug was causing it.

1 Like


Just got my NUC & did the install, all went without a hitch, had to disable secure boot.

Only issue I’m having is it not finding my Logitech Bluetooth keyboard, working through that now…

Running really smoothly on the NUC though

1 Like

In EndeavourOS, Bluetooth is not installed or enabled.
See this post for further information.


1 Like

Yep, did that seems a bit device specific maybe.

Had it connected but as soon as I switched it to the other computer and back it gets stuck in a disconnected/ connected cycle

Got it, arch wiki to the rescue