NUC 11 with Hybrid Graphics Freezes Console Login

Hello! I am a first time poster but several-year EOS user. After the past several weeks when time has allowed, I have exhausted all my best research effort and patience trying to resolve an issue. Before considering the “nuclear” option of reinstalling, I am writing today seeking constructive advice and assistance from the EOS community!

A few months ago I purchased a NUC 11 and wanted to continue using EOS like I had without incident on my NUC 5 for the past several years. Using EOS has been my gateway to Arch distributions and I have learned a lot from the extensive Arch Linux wiki and EOS community posts. I otherwise have used other Linux distros such as Fedora, Ubuntu, and work with RHEL on a regular basis in my 23 year IT career. This is my first experience however working with a non-Windows computer having dual GPUs.

Ultimately I want to resolve this issue resolved so it can be my new “daily driver” for general computer use and occasional gaming. The end goal after getting things “working” is to use hybrid mode for graphics, and NOT use an X greeter. On my NUC 5, I have been using EOS for a few years and had converted the default XFCE install to use BSPWM. I changed the default boot target to multi-user then use startx to run X windows. For the NUC 11, I anticipated minor customizations would work and avoid a default installation and modifying afterwards.

I had no issues selecting the NVIDIA driver option and booting to the XFCE desktop from the Live CD to start the installation. The slightly custom installation appeared to complete successfully. The main custom options were to use F2FS as root filesystem, BSPWM window manager, and no X windows greeter. However after the installation, all subsequent boots hang. EOS simply will NOT complete a “visually successful” boot.

To gather evidence for troubleshooting, I either boot from the Live CD and arch-chroot in the mounted file systems or have sshd enabled then remote secure shell. The only way I can log in from the console otherwise is using the nomodeset kernel option.

According to journalctl --boot 0 --dmesg, the systemd boot sequence completes no issues.

Here are some details about my NUC 11.

EOS Version: Cassini Nova R1
Hardware: NUC11PHKi7C

Using similar Live CD command-line options, the system hangs on boot.

$ cat /proc/cmdline 
initrd=\4ba8052a8d764f7f8ab9d89a0199cadb\6.2.12-zen1-1-zen\initrd nvme_load=YES nowatchdog rw root=UUID=fa613490-f136-4bc9-ac3c-56e30a0b5ff5 systemd.machine_id=4ba8052a8d764f7f8ab9d89a0199cadb verbose loglevel=5 nvidia nvidia-drm.modeset=1 i915.modeset=1 nouveau.modeset=0

Note: Same issue when using the regular kernel or a fallback.

Some graphics card information by lspci:

$ lspci -nnk | grep -iEA2 'vga|3d'
00:02.0 VGA compatible controller [0300]: Intel Corporation TigerLake-LP GT2 [Iris Xe Graphics] [8086:9a49] (rev 01)
	Subsystem: Intel Corporation Device [8086:2090]
	Kernel driver in use: i915
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation TU106M [GeForce RTX 2060 Mobile] [10de:1f15] (rev a1)
	Subsystem: Intel Corporation Device [8086:2090]
	Kernel driver in use: nvidia

Here is inxi graphics output:

$ inxi -Gxx --display
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel arch: Gen-12.1 ports:
    active: none empty: DP-2, DP-3, DP-4, DP-5 bus-ID: 00:02.0 chip-ID: 8086:9a49
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Intel driver: nvidia v: 530.41.03
    arch: Turing pcie: speed: 2.5 GT/s lanes: 4 ports: active: none empty: DP-1,HDMI-A-1
    bus-ID: 01:00.0 chip-ID: 10de:1f15
  Display: server: v: driver: X: loaded: N/A unloaded: modesetting failed: nvidia
    gpu: i915,nvidia note: X driver n/a
  API: OpenGL Message: No GL data found on this system.

Some other options used:

Dracut additions:

$ grep -hv "^#" /etc/dracut.conf.d/*.conf | sort
add_drivers+=" nvidia nvidia-drm nvidia-modeset nvidia-uvm "
omit_dracutmodules+=" network cifs nfs brltty "

Modprobe updates:

$ grep -hv "^#" /etc/modprobe.d/*.conf | sort
blacklist apple_mfi_fastcharge
blacklist cfg80211
blacklist iwlmvm
blacklist iwlwifi
blacklist mac80211
blacklist nouveau
blacklist pcspkr
blacklist rfkill
install apple_mfi_fastcharge /bin/false
install rfkill /bin/false

I have no need for wireless on a desktop system. Some of the items are defaults from the original installation or anticipated future customizations.

And here is a listing of relevant kernel modules loading:

$ lsmod | grep -E 'i915|nvidia'
i915                 4042752  1
drm_buddy              20480  1 i915
ttm                   110592  1 i915
drm_display_helper    221184  1 i915
cec                    98304  2 drm_display_helper,i915
intel_gtt              32768  1 i915
i2c_nvidia_gpu         16384  0
nvidia_uvm           3190784  0
nvidia_drm             98304  0
nvidia_modeset       1519616  1 nvidia_drm
nvidia              61702144  2 nvidia_uvm,nvidia_modeset
video                  77824  2 i915,nvidia_modeset

Also variants changing i915.modeset=0 and nvidia-drm.modeset=0 do not make any difference in console access, except with inxi not seeing graphical drivers loaded.

Relevant packages installed:

$ yay -Q | grep -E 'intel|^linux|nvidia|mesa|vulkan|xf86' | sort
intel-ucode 20230214-1
lib32-libxxf86vm 1.1.5-1
lib32-mesa 23.0.2-2
lib32-nvidia-utils 530.41.03-1
lib32-vulkan-icd-loader 1.3.245-1
lib32-vulkan-intel 23.0.2-2
libxxf86vm 1.1.5-1
linux 6.2.12.arch1-1
linux-api-headers 6.1.9-1
linux-firmware 20230210.bf4115c-1
linux-firmware-whence 20230210.bf4115c-1
linux-headers 6.2.12.arch1-1
linux-zen 6.2.12.zen1-1
linux-zen-headers 6.2.12.zen1-1
mesa 23.0.2-2
mesa-utils 9.0.0-2
nvidia-dkms 530.41.03-1
nvidia-hook 1.3-1
nvidia-inst 23-5
nvidia-installer-common 23-6
nvidia-prime 1.0-4
nvidia-prime-rtd3pm 1.0-2
nvidia-utils 530.41.03-1
vulkan-headers 1:1.3.246-1
vulkan-icd-loader 1.3.245-1
vulkan-intel 23.0.2-2
vulkan-tools 1.3.245-1
xf86-input-libinput 1.3.0-1

I hope that another set of eyes is able to see something I missed!

Thank you so much in advance!

I found some leads earlier in the week and finally had the chance to post them.

I tried to configure fbcon but this did not resolve the issue.

However I was able start X windows blind, similar to what a user reported on the ArchLinux forum. Now at least I experienced similar behavior as others now, ruling out faulty hardware.

I also re-reviewed the NUC11PHKi7C Technical Product Specification. In section 2.1.5 there is a very informative block diagram of the components and their connections.

The NVidia card is connected directly to the HDMI and Display Port connections. While the Intel Xe is connected to Thunderbolt.

I did not mention that previously I was using the HDMI port to connect with my monitor. For reasons I still do not understand, even though I had early KMS loading for NVidia enabled, it still did not activate properly at start up.

So I decided to purchase a USB C to HDMI cable and make the video connection to the monitor this way. Voila! After log in I have a console! Even X windows worked!

Now I can focus on tweaking and setting up “PRIME GPU offloading”!

I hope this information will help at least ONE other person with a NUC11PHKi7C using Linux too!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.