Nothing to update

Hello and thanks
I installed the last version 17-04, then tried to do a general update, both with pacman -Syu
and with the GUI, but it seems there is almost nothing to update, just a minor short detail was updated.

Then installed firefox to write this message and it worked.

It tells the system is updated and there is nothing to do.

But this release should be from April. How is it possible that from April there is nothing to update?

1 Like

Hello @francus
EndeavourOS is a rolling release with all packages being the latest when you install. Don’t worry updates will happen frequently.

If you did an offline install there would be updates as the image is static when the ISO is created. It appears you have chosen an online install method which is a net install so it is currently up to date. Don’t be surprised if by later in the day you see some updates as Arch updates pretty much daily. You can check for updates via the checkupdates command via terminal :wink:


Welcome to Endeavour OS forum @francus!

1 Like

should be already installed per default also :wink:

And welcome here from my side too!

Welcome back! :smile:

You can give a terminal command

  pacman -Q linux

and you should get this output:

  linux 5.12.10.arch1-1

It that happens, your system is very likely OK.