Not enough memory on online installation

Hi guys,

anyone of you faced similar issue with new ISO?

The system does not have enough working memory. At least 2.4 GiB is required.

My computer has 8GB of RAM, so it should not be a problem. Laptop model Lenovo Yoga 700-14ISK. This happens, when I try to run Online installation. Install log: https://pastebin.com/eNhaRyGY

Welcome! :smile:

Your internet connection is not working well. What connection are you using?
Could you show the output of the following terminal command about your machine:

inxi -Faz | eos-sendlog

You can also try the offline install mode. It brings you the Xfce desktop.

     RAM :   2576980377 
     enoughRam :   false

it shows 2.4GB and on testing we never saw false detection, you could show some hardware information to confirm?
inxi -Fxxc0z --no-host | eos-sendlog from LiveSession
or only to see if RAM will get detected nicely:
sudo inxi -ma → send pastebin → sudo inxi -ma | eos-sendlog

sorry, my bad. I was trying to replicate this issue and I was sure that I will still get memory error, so haven’t connected to network. and I am right. new log, except that I am connected to WiFi: https://pastebin.com/TiS0JL3s

and another link from terminal command: https://clbin.com/NMCxA

https://clbin.com/c6F4s

this is what Windows shows:

image

and this is from BIOS:

Info:      Processes: 193 Uptime: 10m wakeups: 1 Memory: 2.01 GiB used: 1.8 GiB (89.7%) 

Somehow the memory is not detected as 8 GB but 2 GB.
Or the memory could be broken, have you tested the memory?

Memory: 2.01 GiB used: 1.82 GiB (90.6%)

It says … what shows freeand may try to look at glances from terminal… you ca also simply try to remove the limit on RAM and see if install is not running out of memory … but it can be also defective hardware or loose RAM.

If you want to try to disable the limit:

sudo xed /etc/calamartes/modules/welcome_online.conf
and set RAM to 1.0:

free -h

would be interesting to see the result of the command above.

image

will try to set this option and check how it goes

So that too shows 2.0GiB of RAM.
Interesting.

Could you run this program:

sudo lshw | grep -A8 bank

It is in package lshw if you don’t have it yet:

sudo pacman -S lshw

image

after updating this, I was able to bypass requirements check, but this seems strange to me:

shouldn’t I see automatic partitioning option?

That only happens if a live install fails and you try again. You need to reboot instead and start the live iso and installation again.

after several more retries, I gave up. I just tried Fedora 35 and it works fine:
image

if there are no other ideas, I guess I will wait for another ISO and try then.

gave it several more tries and now succeeded.

  1. bought new USB drive and tried with new ISO - same, not enough memory
  2. downloaded older ISO and booted - installed successfully. no errors during installation, even though it showed that I have 2 GB RAM.

After installation, it shows that there are 8 GB RAM on computer:
image

We are working on this to find the root cause, and hopefully have a fix or a workaround for the next ISO release.

The previous ISO is also a reasonable way to do a fresh install. A rolling distro will keep packages up to date all the time.