[not a bug] Partial Black Screen Post-Update

Still in the process of updating with different packages deselected to find the culprit, but I’ve not been able to update my desktop system for the last week or so as when I do, rebooting leads me to the IRQ error, loading arch 246, cleaning inode 2349853/38492895 something something screen, which then loads a mouse cursor and then just stops.
Switching to tty2 and trying to startx manually gives me 3 white terminal screens on a black background, two of which I can type ‘exit’ and they dissappear, the third will shut down whatever X server was running.
I’ve tried leaving out Nvidia packages, Mesa packages and kernel updates and have the same problem each time.
KDE Desktop, Nvidia 1650 Super on a Ryzen 3000 platform

Quick update, got most packages installed (creating timeshift backups each incremental update). The only ones remaining are linux kernel, linux headers, anything with mesa, anything with Nvidia and anything with systemd/x.
Installing just the nvidia things stops x from working and I don’t even get a mouse cursor on afformentioned black screen from original post

To start Plasma with xinit/startx, append export DESKTOP_SESSION=plasma and exec startplasma-x11 to your .xinitrc

the terminals shown are a simple minimal xorg environment only…

There seems to be an issue on kde itself or related to something with xorg… we do see that some users reporting similar issue.

It would be helpful to get some boot logs as without any it is hard to find a workaround.

journalctl -b -0 | curl -F 'f:1=<-' ix.io
1 Like

rolled back and installed only the kernel, headers and vulkan, same problem.
Heres the logs:

Another final update, I have gotten every package to install except for the following:

  • lib32-mesa-20.1.8-1
  • lib32-nvidia-utils-455.23.04-1
  • libxnvctrl-455.23.04-1
  • linux-5.8.10.arch1-1
  • linux-headers-5.8.10.arch1-1
  • mesa-20.1.8-1
  • nvidia-455.23.04-1
  • nvidia-settings-455.23.04-1
  • nvidia-utils-455.23.04-1

Installing ANY combination of those packages breaks the system, everything else on the system is fully up to date.

Sep 22 20:03:15 VoyagerMango kernel: nvidia-gpu 0000:09:00.3: i2c timeout error e0000000
Sep 22 20:03:15 VoyagerMango kernel: ucsi_ccg 0-0008: i2c_transfer failed -110
Sep 22 20:03:15 VoyagerMango kernel: ucsi_ccg 0-0008: ucsi_ccg_init failed - -110
Sep 22 20:03:15 VoyagerMango kernel: ucsi_ccg: probe of 0-0008 failed with error -110

could be the issue… i would try using nvidia-dkms package as it builds modules on its own…

I tried dkms back in my manjaro days and had a terrible time of it. What specifically does this entail? Do i just install nvidia-dkms instead of nvidia-455? Does the dkms include everything else like lib32 and nvidia-settings/utils?

1 Like

This probaly did not work very well in the past with manjaro because of how many modifications to upstream Arch packages they make as well as to driver packages. Here on EndeavourOS you are just a step away from Arch so it should be a much more pleasant experience for you. As for what it brings with it here is the package:

As you can see it pulls in nividia-utils in as a dependency.