Normal Shutdown Behaves Weirdly

I’m not sure if this fits in this category. But at least better than in general topic

Few days ago, I experienced blackout in my place. My laptop’s battery is dead, the my machine just died. Since then, shutdown process has been bad. Normal shutdown behaves like forced shutdown (long press on power button). I know this from the fact it simply kills my HDD (you know , the sound of HDD just died) instead of gracefully shutting it down

When the blackout happened, I was not in update process. I was just watching some videos. So botched update is not an issue

I tried things:

  • changing desktop environment (from Xfce to Plasma)
  • changing kernel
  • installing nvidia-open (because it’s suggested by people on Telegram group)

And nothing changes this behavior

Hardware failure is not an issue either, since I can shutdown normally under Windows 10 and Live Session

What can I do other than reinstall my system?

You should look in the log to see if the system is shutting down properly or not.

It is

Here’s the pastebin link

It does appear to be properly unmounting your filesystems so it isn’t really behaving like a hard poweroff.

Which kernels have you tried?

Oh. I’m sorry. I can’t read logs properly :frowning:

Kernels I tried are the LTS and “normal” one

And both do this

I don’t think it’s kernel issue, because sudo power off -f works

Solved by reinstall

Well, now you’ll never know what the cause was. A pity, it was an opportunity to learn something interesting.

Already took too long and too much of my energy. I want to use my computer, not tinker with it to no end

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.