NordVPN and BBC Iplayer

With a fresh install of EndeavourOS, I installed Nordvpn and went through the documented steps that it spits out on the terminal and I have also double checked with the Arch wiki with no issues. However, when I connect to a UK server and attempt to watch BBC Iplayer it still gives me the “not in UK” error on the website in Forefox. I have uninstalled, reinstalled Nord. I have cleared cookies and all of the history and cache multiple times and have done my due diligence on restarting the daemon a few times among other things like playing with obfuscated servers, messing with my network connection and settings, turning off IPV6, etc.

I was wondering if I’m just being crazy and NordVPN is having the issues right now with PCs, as it works on my phone with the same UK server, or if I’m missing anything with a clean install dependency-wise, application-wise or setting-wise. It’s driving me nuts as it worked fine in manjaro, but not here which leads me to believe there is something I’m missing or not doing right. I have experience with Arch but it’s been a while getting back into the “not holding my hand” routine.

First steps, because you did not mention this, would be to see if you’re connected to a UK IP. What does show?

Have you been able to watch iPlayer on your computer, whilst connected to NordVPN before? I tried connecting to a server in Manchester, and bbc’s website does not let me use iPlayer either. Based on this page it seems like there’s a chance VPN IPs are blacklisted. Since you mentioned you can watch on your phone, I would make sure it is connected to the VPN (again, see what ipleaks tells you) and report back.

Ipleak tells me I’m in the UK. No leaks. Nothing strange.

I have been able to before. Just a few hours before I switched to Endevour even. That’s what’s so odd about it.

Very odd. Anything else that is different? What OS did you run before? There’s of course the chance that the IP has been added to a blacklist since then, but it does seem odd.

I ran Manjaro. Then switched yesterday. Nothing is different. Same connection, same router.

No reason EnOS would be the cause of this. Most plausible explanation is that it’s something on NordVPN’s or BBC’s end. Last thing I can think of is if your Chromium fork doesn’t ship with the necessary plugins or has modifications preventing fingerprinting. Perhaps worth a shot to install barebones Firefox or Chrome to see if it runs. Otherwise I’m out of ideas.

edit: It is asking me to log in when connecting from a UK IP via barebones Firefox. I’m not sure if this is new or the expected result, but seeing as I was blocked earlier whereas now it prompts me for credentials it does seem to indicate there was/is something on BBC’s end.

Aha. Okay. I will give it a shot soon and see what happen via barebones Forefox or just connecting. Thank you for some ideas as I was banging my head against a wall figuring out what else I can do.

Edit: So, what it took was I had to remove my .mozilla folder and reinstall firefox(whether that was needed or not is questionable) and now it works fine. I am elated as I can continue olympic watching and disappointed at myself that the solution was just that simple. Thank you very much for the suggestion to get me on the right track.

Glad you got it working.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.