Noob question

is it alright to run “sudo pacman -Syu” while inside a git directory?

You can run that from any directory.
It makes no difference what your pwd is.


i see. I only asked that because I was unsure what caused my system to not boot after running that command recently

That must have had other reasons which would need troubleshooting.
The directory where you ran it from is not one of those.

By the way, I see now that this is your first topic on the forum, so welcome to EnOS’ community @rafaeljacov!

:enos_flag: :handshake:t5:

Thanks. I’m using vanilla arch currently since i had to reinstall EOS via online installation but didn’t work unfortunately. As I’ve told before i ran the update command then reboot but the next thing is my System wont boot. the error msg says it “failed to mount /boot. cannot read vfat signature” or something like that. i went to fdisk to erase the signature but still no luck


Since your initial “issue” is resolved, I would suggest to open a new thread with an appropriate title, something like: System won’t boot after update: failed to mount /boot.

You will get more eyes on the issue.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.