Nomachine inbound working on 1 of 3 EOS installs

I know this isn’t the NoMachine support forum but I posted over there a few days ago and emailed them with no response so decided to take a shot here with this.

I have 3 machines, all running EOS, all fresh installs. I can use Nomachine to make outbound connections to other boxes in my house that are running Windows 10 and Mint with no problem. BUT, out of all 3 of these boxes running EOS, I can only use Nomachine to connect to one of them. When I try to use Nomachine to connect to my EOS boxes, only 1 works and the other two EOS boxes give me a ‘connection reset by peer’ error.

None of these PCs are running firewalls or security software. All are plugged into the same switch. Any ideas?

Thanks JR29 but I’ve been through that wiki and still no go. Like right now, I’m on a fresh EOS install. I can successfully connect to another fresh EOS install I did on another computer with Nomachine and it’s working fine. However, from THAT machine back into this one… ‘connection reset by peer’. All 3 of these computers are running EOS/Cinnamon.

it must be an absent library

That’s a possibility but all 3 of these EOS machines were set up around the same time. I can remote into two of them but trying to remote into this one in particular results in the ‘connection reset by peer’ error.

to me that sounds like a network issue, I use nomachine on three fo my computers, but they are all antergos gnome installs without issues. However, when I try to connect to my mothers computer which is ubuntu I get kicked off all the time because her network is a mess. Are you trying to connect via lan or via internet?

All these computers are in my house, connected to the same switch.

I have no experience with nomachine. According to the wiki article @JR29 referred to, it doesn’t use ssh, which is more in my experience.

However, the ‘connection reset by peer’ is a standard error described as

In my experience, this error usually means there is a mix up with ports. The port specified by the sending machine (client) is not open or is assigned to a different service on the receiving machine (server). I saw in the wiki article that nomachine usually uses port 4000. Check in the nomachine configuration files for assigned ports and protocols. I would ASSUME TCP for the protocol, but it might also use UDP in conjuction with TCP. See what you come up with.

EDIT: I assume you have the free version?

Yes, using the free version. It’s listening on port 4000

tcp        0      0  *               LISTEN      7586/nxd 

The server is listening on port 4000 using TCP, that’s good.
Is there a way to see what port the client (the computer that won’t connect) is sending the requests on?

I’ll install Wireshark next weekend and mess around with it. We can let this thread lay dormant in the mean time. I’m sure the connection is being made because the target PC connects for a split second then closes the connection. I reloaded a test machine right beside me with EOS again and installed Nomachine. I can remote into it perfectly fine but it can’t remote into my ‘server’ PC.

One thing that is different between them… the test PC has a DHCP assigned IP address and the server (the one I can’t connect into) has a static IP. I’m going to give my test machine a static IP and see if that breaks it. If it does, maybe that’s a clue of some sort?!

I think you are on the right track.
The only other thing I know of that can cause that error, at least in SSH, is keys being out of sync.
The arch wiki says that the free version does not support SSH. However, in the really poor documentation on the nomachine site I did see them mention keys. Not sure if they were referring to SSH keys on the paid version, or if the free version uses some form of keys?

Good luck, I’m sure you will figure it out. Let us know how it turns out.

So I gave the test machine a static IP and I was able to connect into it perfectly fine so that was a bust. I emailed their support people and haven’t heard anything back and it’s been about a week.

Anydesk just seems to keep crashing on me (it hates all my computers).

TeamViewer keeps complaining about me trying to use their free version for professional use (even though I only connect to maybe 4 PCs in my house.

Any version of VNC fights me tooth and nail to get it working.

Is there a simple, remote control utility out there I’m not aware of? One that has an easy server/client setup?

What is it that you are trying to do? Do you need to access a graphical desktop of a computer over the network? Or just trying to set up a server to serve files and stream media?

If you need to access a graphical desktop, I can’t help, I’ve never done that. You would have to teach me how to do that.
If you want to set up one dedicated central server, that’s nothing but a server for files and media, and every other computer is simply a client? With easy back up of data. I would build my own.
I’ve been doing that for years, at least a decade. No lost data yet. Fairly bullet proof. And I can help you with that.

Yep, need remote control/graphical access to other PCs in the house. Speaking of, I just remembered another difference between those computers… the sever has dual NICs. Only one is plugged in though… wonder if it’s something stupid like it connects one NIC 1 but wants to talk back on the other?! I will experiment with disabling the one that isn’t plugged in or heck, wire it into the switch.

As for media server, I built a Plex/Emby/file sharing server a few years ago when I “cut the cord”. Was running Mint for a while and just now switched it over to EOS. Using MDADM raid 6 and a LSI HBA to combine the drives. If you have experience with 10Gbps networking, I’d like to pick your brain on questions surrounding that.

when I use NoMachine internally I make sure all my computes have static IPs internally. I’ve never had it work reliably otherwise. You state that anydesk, VNC both give you issues as well. While I find VNC slow it generally just works turn on server and connect with client. I would suspect a network issue. If you just ssh into the machine is the connection stable?

On 10 Gbps I am at the same stage as you. Looking into it.
When I remodeled the house, I put at least one LAN jack in every room of the house. Except for the bathrooms. So all my cables are inaccessible in the walls. I think I used cat6 or cat6e, can’t remember which. However, I watched a video on U Tube where someone experimented with 10 Gpbs on cat6. Maximum length for cat 5 and cat 6 is 328 ft. So all the specs have to meet that maximum.

In this guy’s case, the longest run in his house was 30 ft, 1/10 th the max. At 30 ft, 10 G worked fine for him. He then got a box of cat6 cable and made a very long cable and tried it. Made the cable shorter until it worked reliably. I don’t remember what his max length was, but it was much longer than the max length I will have. So, based on that I am thinking about it.


Well, Anydesk gave me problems with not sending the proper characters when typing in passwords and stuff. Like what I was typing from the client PC wasn’t being sent correctly to the machine I was dialed into. There was that problem and the other issue was the Anydesk app was constantly crashing on the server. Had this problem when my server was running Mint as well so I doubt it’s an EOS problem.

Looks like I’ll need to give VNC another shot.

If I go the 10Gbps route, it’s just going to be so I can have my server talking to a backup server at 10Gbps. I’ll probably use a Dell 5524 switch (24, 10/100/1000 RJ45 jacks and 2, SFP+ ports) off eBay ($100’ish) and some 10Gbps NICs ($50-$100).

Maybe somebody has the answer to this question… with 10Gbps NIC (stupid newbie question coming up)… it seems that almost all of them require drivers that need to be compiled and added to the kernel. If I updated the kernel later on, will I need to re-do this compiling again or will the new kernel update auto-magically pull in stuff like that? Or, does anyone know of any 10Gbps NICs that are supported “out of the box” with the LTS and/or current kernel?

do the nomachine logs show anything other than the host reset error?