No X after installing Nvidia Drivers GTX 1070

I’m also having this issue. I installed Nvidia drivers and rebooted and now it hangs at boot. I have the i7 12700 and GTX 1070 and I’m using i3-wm. I don’t know how to fix the issue and thank you guys for everything.

Have you tried adding ibt=off to the default grub command line and then update grub with the proper command.

Edit: What does this show

inxi -Ga
1 Like

Can i do this from the grub kernel selection menu before boot? I can’t even get in

Sorry missed your instructions

hey @Dankrr i move your post, please do not necrodump old threads.

First …welcome here :enos:

To be able to help you fast and easy we need exact info on how you do install Nvidia, we do not know that there are endless possible ways you could have done that.

From grub menu you can edit kernel options and also option to boot without loading X … but in most cases you should be able to boot as you do before to black screen and press Ctrl+Alt+F3 which should show a login prompt … from there you can get info and fix the failed attempt to install Nvidia drivers.

I apologize for the Necro post. I installed the Nvidia drivers with nvidia-inst and with --32 at the end.

I tried to Ctrl+alt+f2 and unfortunately it didn’t work either. Froze unfortunately

shows it is enabling i915 what could indicate intel igpu ? aka may optimus hybrid graphics notebook?

I would revert to nouveau open source drivers for nvidia and start over so you will be able to check hardware and options first.

but for this you need to be able to login to install system first …

from there you can run nvidia-inst -n reboot and you should boot to Desktop again.

You need ibt=off kernel parameter. On boot hold Shift to reach GRUB menu, hit “e” to edit default entry, add ibt=off to the end of the line that starts with “linux”

1 Like

That did the trick. I wasn’t sure where to add ibt=off but that fixed it for me. Thank you

You still have to add that permanently to the default grub command line and update grub with the proper command.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.