No Wifi or Internet, Please Help?

I bought a refurbished desktop expressly to put linux on it. The last time I had a desktop, wifi wasn’t even really a “thing” yet, or at least I was too poor to have it, and last time I had Ubuntu this wasn’t a problem because when we did get wifi, it was still plugged in.
So now, I’m faced with a computer which for some reason came with no wi-fi capability (but you get what you pay for so I’m not complaining) and a dongle which claimed to be linux friendly and has given me nothing but grief. I’ve tried pretty much everything, but when I put in

$ ifconfig wlan1

all I get is lu and ethernet, if I recall correctly, but rest assured, wlan1 and wlananything are not on the list.

One of the tutorials I tried to follow was talking about using pacman and AUR and gitclone yay but once I got to the gitcloning of AUR, it was like “Can’t connect” or “can’t resolve host”. Do I need to get my aunt to hook it into the wall just long enough for me to install the driver, or should I just buy a different dongle? IS there a more compatible wifi dongle than the TP-Link AC600? One that just works out of the box? It seems like no matter what I’m in for it. Am I better off returning to Ubuntu because I’m just not ready for Arch?

This might help:

So you would need those “kernel drivers” to get it to work.

Does “lsusb” recognize the usb dongle?

It does. I wrote down that at the end of its name is RTL8811AU, which I figured was the driver [and it seems I was correct] but even with DKMS, if I have no internet on the linux half of my computer, how do I get the driver there?

You need to have dkms package installed, also your kernels header files need to be installed.

After those, you need to install either rtl88xxau-aircrack-dkms-git or rtl8821au-dkms-git from AUR and after make sure the module is loaded in boot.

header files?
and like I said, I tried to do that with git before, I believe it said that both Git and DKMS were already installed and nothing would change, so I said “no, don’t install” and when I tried to install it was like “can’t connect”. So… I guess I’ll try AUR? or does that also require a connection?
Endeavor keeps saying “Cannot Connect to the Internet, would you like to Quit?” in a popup, too.

Sorry, like I said, it’s been a while.

You need to have internet connection for the computer to install those.

So you need the following packages:
linux-headers (or linux-lts-headers depending which kernel you have)

Then you need to install one of those AUR packages:
yay -S

And afterwards load the module for the dongle

1 Like

I… have Endeavour Atlantis.
So, wait, should I not have the dongle plugged in? Or do you just mean the driver?

Honestly, right now, I don’t know how I’m going to get a connection because we’re 100% wireless right now, and I’m not calling AT&T out here to give me a new setup for a temporary circumstance (hopefully) because this is the problem I had before. I just don’t get how i’m supposed to be able to download something from the net when the problem is that I don’t have internet access on that partition of my computer… sorry, i’m not frustrated with you, you’ve been great, I’ve just been working on this for days now and it’s something so basic and on top of everything else it’s just really maddening.

1 Like

Do you have the possibility to connect your cellphone to the computer with a USB cable and tether its internet connection?


If you have AT&T you will have a wifi gateway. This device should have a number of rj45 jacks in the back usually three or four in addition to the WAN. Get a cat6 cable and plug it in. No need to call AT&T, if not try the usb tether as @pebcak suggested.


Okay, I will try that out today.
A cellular connection might be easiest, yeah, because it’s in a different room from the main hub, and there’s no hubs at all in this room. Wow, thanks, I hadn’t thought of hooking my phone up at all.
I’ll let you know how that goes!


OK! So, oddly, I didn’t have to install yay but I did install dkms and after cd’ing into the clone’d aur and makepkging (which first failed, then I installed dkms, and apparently my headers were up to date)
I don’t know how, and I don’t know why, but when I rebooted, it recognized my wifi and asked for a password :3
thank you so much everyone!

1 Like

Yay comes preinstalled with endeavourOS. Yay can install AUR packages just like you can use packman for official repos. But you can also install AUR packages with the “normal way” by using makepkg

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.