No wifi on wake from suspend

I’ve noticed that often when my laptop comes from suspend and I login the wifi isn’t working.

  • XPS 15 (02:00.0 Network controller: Broadcom Inc. and subsidiaries BCM43602 802.11ac Wireless LAN SoC (rev 01)
  • Gnome with GDM

Let me know what oter information you need.

Hello, @inverse Are you using the dkms version of Broadcom? If not I would try that and see if it makes any difference.

Thanks @ricklinux - will give this a go and report back!

When installing the dkms version I have no connection :frowning:

@ricklinux any ideas on how to debug why it didn’t work?

I just installed broadcom-wl-dkms which replaced the non dkms version and rebooted.

You also have to install linux headers. I hope you are able to connect via ethernet to do this? This is for the current kernel.
sudo pacman -S linux-headers

I apologize if i have caused you any problem here. I forget that not everyone sees the info on the wiki and assume they know that the headers are needed also.

@ricklinux - No worries I can tether my phone.

I had those headers installed as per arch wiki but even with these instructions I was unable to get it working.

tried sudo mkinitcpio -P after ?

I usually install the headers again and reboot. Or as @ringo say’s sudo mkinitcpio -P after. It should work if the Broadcom driver currently works. If you are able to give it another try installing broadcom-wl-dkms and then install linux-headers and reboot and see. I have this Broadcom chip running on mine and that’s how i install it and it works no problem.

03:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter (rev 03)

@ricklinux

I tried exactly what you suggested to no avail :cry:

@ringo even running sudo mkinitcpio -P afterwards and rebooting again

Back to the non dkms install for me. Perhaps sometime this week i’ll rebuild and see if that helps.

You can try this maybe turning off power management to your wifi. If it doesn’t work you can turn it back on. Get your device name.

iw dev

Then try this withxxx being your device name.

iw dev xxxx set power_save off

Example:

iw dev wlp58s0 set power_save off