No Wake up after longer suspension

Hi Rick,

after the laptop crashed earlier today and a fresh install was necessary i decided to pick KDE in Calamares.
And it seems to work perfectly now. I opened the lid after the laptop had “slept” for two hours. It took about a second to show the lock screen and I could enter my password.

I love Gnome. However, it seems it doesn’t want to work for me. The brandnew XPS 15 i mentioned further above always complained about the fact that there was no lock screen with Gnome installed. So i could not make it sleep. This machine does not wake up with Gnome installed. This all sounds a little weird, I am aware of that. However, i need the machine for work, my work is not to install an OS and make it work flawlessly. Sounds arrogant, isn’t meant arrogant.

Thanks for your support, i do appreciate your help a lot really. Keep your fingers crossed that it works better with Plasma :slight_smile:


I’m not as familiar with Gnome desktop and i don’t use a laptop. I am mostly a desktop guy. I use Plasma also plus Cinnamon and Xfce. There are some issues with the lock screen on the laptop on Gnome. You have to enable or change something for the lid close settings. Off the top of head I’m not sure exactly what to tell you about it. I would have to find that info but I know there is some issue in that regard. I’m glad you got it working. If for some reason you decide to change i do recommend Xfce or Cinnamon also. They both are excellent too.

1 Like

There is never a stupid or embarrassing question :slight_smile: So long as you are willing to learn and try things out :wink:


thanks a lot, slayerproof and everybody.
This friendliness and the support is what keeps me working with EndeavourOS.
An OS for me however is an OS. Installing an OS is not my work, an OS is a tool basically to get my work done. A few adjustments here and there, picking up some new stuff to get going with Linux, that’s absolutely fine for me. I am not quite willing however to spend hours and hours to make an OS work. or, in this case, a desktop environment.

I am so proud to announce my solution to the problem:
a) wipe disk
b) install endeavourOS with KDE

Thanks again, cheers,


KDE :partying_face::partying_face::partying_face::partying_face::partying_face::partying_face::partying_face:


Adding this because I can’t post only the first line :rofl: