No ssh access with putty

Hello,

ssh remote access via putty doesn’t work. openssh is installed by default, I see. I am using IP and port 22. What is the trick?

1 Like

For me putty works fine with the default configuration.
By default settings : If you get a “Fatal error” Message like “unable to open connection to IP-adress …” - check if you have typed in the correct IP.

Hello,

the IP is correct, has not changed. I press “open” and get
Network error: Network error: Connection refused”.

Hello,

I had to activate it additionally.

> sudo systemctl status sshd	
> sudo systemctl start sshd	
> sudo systemctl enable sshd	

ssh works now.

1 Like

Thank you for posting your fix…
You helped me fix mine too… Lol
I did a Arch from scratch install a month or so ago and I just installed ssh to log into my server from this computer and found out that It was not working… :frowning:
Anyway I now have ssh working also… Thank You!
LLAP

ArchiBald, you don’t need root privileges for the status query:

systemctl status sshd

1 Like

Thank you for the information.
Yes, I did know that I need to use SUDO… :wink:
LLAP