No sound card detected at fresh install

Hello, I have been working with EndeavourOS quite a time, but now my laptop got screwed, so I bought a new one Dell G3 3590. Installation was smooth and everything OK, I configured my gnome and everything else, but then I tried to play a tutorial on youtube, and SURPRISE! no sound at all…

I thought it was a BIOS/kernel bug by reading some articles of arch wiki, but today with updated BIOS installed and the new kernel update, the problem still exists.

Can you guys help me, please?

Hello @James_Kodiak

Have you looked at the wikki to try to resolve it?

Can you also post the output of inxi -Fxxxza --no-host? Inxi is an AUR package so yo will have to install it if you don’t already have it. Fortunately endeavourOS comes pre-configured with the AUR helper yay. There are a couple of ways (like so often in linux) to do this.

  1. Use your package manager of choice if you have one installed with AUR support to locate and install the package (inxi).
  2. Use the terminal. This can also be done a few ways. First you can input yay -Ss inxi that will list the inxi related packages. (You want the one that is called inxi). Then input yay -S inxi to install it. Second way and I find easier is to input yay inxi This will also list the inxi related packages but this time each will have a number. Then all you need to do is select the number of the package to install it.

Lastly,
welcome

1 Like

Ok, will check it

Hello @Elloquin, here’s the result:

 System:
  Kernel: 5.5.3-arch1-1 x86_64 bits: 64 compiler: gcc v: 9.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-linux 
  root=UUID=f901521a-731d-4e54-8149-5f42ba53bbba rw quiet 
  cryptdevice=UUID=69c5548d-828b-4a1c-9a62-03811e14215a:luks-69c5548d-828b-4a1c-9a62-03811e14215a 
  root=/dev/mapper/luks-69c5548d-828b-4a1c-9a62-03811e14215a 
  resume=/dev/mapper/luks-69c5548d-828b-4a1c-9a62-03811e14215a loglevel=3 
  Console: tty 0 wm: gnome-shell dm: GDM 3.34.1 Distro: EndeavourOS 
Machine:
  Type: Laptop System: Dell product: G3 3590 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 027M7R v: A00 serial: <filter> UEFI: Dell v: 1.8.0 
  date: 11/11/2019 
Battery:
  ID-1: BAT0 charge: 50.0 Wh condition: 50.0/51.0 Wh (98%) volts: 12.9/11.4 
  model: SMP DELL PN1VN99 type: Li-poly serial: <filter> status: Full 
CPU:
  Topology: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: CA L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 38408 
  Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Dell 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1f91 
  Display: server: X.Org 1.20.7 driver: nouveau compositor: gnome-shell 
  resolution: 1920x1080~60Hz 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: sof-audio-pci 
  bus ID: 00:1f.3 chip ID: 8086:a348 
  Device-2: NVIDIA vendor: Dell driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:10fa 
  Sound Server: ALSA v: k5.5.3-arch1-1 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Dell driver: r8169 v: kernel port: 3000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Dell driver: ath10k_pci v: kernel port: 3000 bus ID: 04:00.0 
  chip ID: 168c:0042 
  IF: wlan0 state: down mac: <filter> 
  Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-14:5 
  chip ID: 0cf3:e009 
Drives:
  Local Storage: total: 476.94 GiB used: 7.80 GiB (1.6%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: PM991 NVMe 512GB 
  size: 476.94 GiB block size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 25304039 scheme: GPT 
Partition:
  ID-1: / raw size: 476.64 GiB size: 468.16 GiB (98.22%) 
  used: 7.80 GiB (1.7%) fs: ext4 block size: 4096 B dev: /dev/dm-0 
Sensors:
  System Temperatures: cpu: 54.0 C mobo: N/A gpu: nouveau temp: 25 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 262 Uptime: 58m Memory: 7.61 GiB used: 2.46 GiB (32.3%) 
  Init: systemd v: 244 Compilers: gcc: 9.2.1 Shell: bash (sudo) v: 5.0.11 
  running in: gnome-terminal inxi: 3.0.37

Can you edit that post and put three ``` before and after the out put. It makes it way easier to read :grinning:

1 Like

Following the hda_analyzer tuto with a few complications because of dead links, I got through this:

Apparently only SPDiF is recognized by endeavourOS, but on live CD everything works well…

Sorry, there you go.

1 Like

@James_Kodiak
What @Elloquin means is it is best to use full window in the terminal when you run the inxi command. Then copy and paste here in the forum but put three tild (~~~) before and after what you paste. It makes it more readable and you also capture everything as opposed to it being cut off.

Edit: As he stated you can edit the post and just add the three ~~~ before and after.

Sometimes it’s just a matter of right clicking on the volume icon and going into the audio controls and changing the output device.

seems like two devices one from motherboard and one from nvidia graphics card device… so may you need to choose the right one to be on and the unused to be off:

run pavucontrol to make this clear:
Bildschirmfoto_2020-02-12_18-13-54

Only the nvidia showing, the one of the HDMI port:
image

Try setting that one to off and reboot to see if it picks up the other device. That is the HDMI out from your video card. you can always turn it back on.

1 Like

It was set “off” when I sent you the SS, i changed it to another setting and reboot, still just shows nvidia…
Turned it to off again and reboot, just nvidia showing.

What shows in the output devices tab?

pacmd list-cards

will give info if pulseaudio knowing about your intel audio device.

you can also try resetting pulseaudio configuration by removing it from users home:

mv ~/.config/pulse ~/.config/pulse.bak
1 Like
pacmd list-cards
1 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_01_00.1>
	driver: <module-alsa-card.c>
	owner module: 6
	properties:
		alsa.card = "0"
		alsa.card_name = "HDA NVidia"
		alsa.long_card_name = "HDA NVidia at 0xa3080000 irq 17"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:01:00.1"
		sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0"
		device.bus = "pci"
		device.vendor.id = "10de"
		device.vendor.name = "NVIDIA Corporation"
		device.product.id = "10fa"
		device.string = "0"
		device.description = "HDA NVidia"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5900, available: no)
		output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 800, available: no)
		output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 800, available: no)
		output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5700, available: no)
		output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 600, available: no)
		output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 600, available: no)
		output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5700, available: no)
		output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 600, available: no)
		output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 600, available: no)
		output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (priority 5700, available: no)
		output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (priority 600, available: no)
		output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (priority 600, available: no)
		off: Off (priority 0, available: unknown)
	active profile: <off>
	ports:
		hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"

image

I have seen this before. Topic here:

1 Like

looks like it is not detected to use with pulseaudio, and “Dummy Output” is shown as HDMI is not connected (unplugged)

to see what was going wrong for the intel audio grep the journal:

journalctl | grep sof-audio-pci
should show error on that
if it is giving out long log try using pastebin and share the url it gives out:
journalctl | grep sof-audio-pci | curl -F 'f:1=<-' ix.io

you can also check if you see intel audio when you are running alsamixer from terminal and pressing [F6] to select audio devices…

2 Likes