No sound but settings seem to be ok

Perhaps try lts kernel? Seem like a driver issue.

Okay, I also found explanation on a page in German language

There they also recommended to remove mainline kernel afterwards.
Another user recommended even to remove GRUB and convert to SystemD to make it much faster but this seems to be not so easy for a beginner so I need to think about.

I explain in my link above how to install lts kernel. No need to remove mainline. You can have both and select at boot. In fact that’s what I use in case on kernel has a problem I have lts as fallback…

Edit: the article you post is missing two other commands.

Also first update your system then run those commands if you want to install lts and give it a shot.

sudo pacman -Syu

You can also use akm if it makes you feel more comfortable, it’s a gui that does the same thing as using the commands above. The first command installs the kernel. The second command updates your grub config. The latter is necessary to see the added kernel in your grub boot list. Here the article from eos wiki.

https://discovery.endeavouros.com/endeavouros-tools/akm/2021/08/

Thanks, I will try out end of this week since I am on short travel.

1 Like

I tried the way via AKM gui, I deselected mainline and I added LTS kernel beside existing stable version. Nothing else. Afterwards I rebooted and I could not start the OS again:
I got error messages
“/boot/vmlinuz-linux not found”
“you need to load the kernel first”

I got panic and tried to install EndeavourOS again from USB stick with LiveOS from the beginning but sorry I was not able to perform the installation (the next button could not be pressed but I did not know what to do or which setting the program expected).

I searched now in internet on another PC and found following solution:

Maybe I get this fix done tomorrow.

But why was it not possible to get EndeavourOS installed from same USB stick with LiveOS again?
16GB SSD was not completely free (EndeavourOS installed) on it.
Can someone give me understandable instruction how to install Endeavour OS again?

Thanks.

I do not understand this part. LTS is the long term stable release. You can just select it at boot and install it along the main kernel provided by eos. No need to delete the other kernel. Good to have to have both ad a backup, at least my opinion.

What exactly did you select? Both lts and lts header?

If you have a live eos you can chroot directly and fix such things, no need to reinstall from scratch or panic. Sorry things got messed up.

What exactly did you try to do at install with respect to partitioning? If you would replace and erase disk, there should be no reason for your system to be broken or complain about loading kernel. A bit more infos will help understand what went one. Again sorry to hear things went bonkers…

I remember I selected only one LTS: So LTS only (the line below the stable version) but not the LTS header (the line below LTS).

Yes, but I was not able to do from LiveOS. I hoped the faster way is new installation (this was the reason).

I had no problem to install EndeavourOS from USB with LiveOS on ‘empty’ SSD:
All the default settings during installation I did not modify.
After installation of EndeavourOS I tried to reinstall again via same way (from same USB with LiveOS) but I was not able to do so (Next button could not be pressed because not enabled).
For me it looks like SSD would need to be formatted again or the disk must be repartitioned again. But I was not able to do so and I think the installation procedure should do this for me. There is a trick needed: I do not know how to do. Sorry, I cannot explain better but I need help.

Perhaps send a screenshot of that installation step. When you come to disk partitioning you need to select the partition you want to erase and install or replace eos with.

I would rather follow a simpler route…

Instead of complete reinstall, what you can try now is boot into live iso, open a terminal and chroot with your live iso then reinstall the kernel via command line. There are plenty of guides in this forum that explain chroot. It is worth to understand how this works if you use an arch based system.

Here is a guide from wiki.

https://discovery.endeavouros.com/system-rescue/arch-chroot-for-efi-uefi-systems/2021/03/

Then you reinstall properly the kernel, here commands I posted above:

Then reboot.

I will try out following command in LiveOS terminal to check the partitions:
sudo lsblk -f
I expect it confirms that I have root file system under sda2 and the (fat32 UEFI) boot partition (default) mounted on /boot/efi and no other partitions (Home and Swap I would ignore).

Then I will execute two mount commands:
sudo mount /dev/sda2 /mnt
sudo mount /dev/sda1 /mnt/boot/efi

Then I will execute
sudo arch-chroot /mnt

Afterwards I will install LTS kernel and update the grub config with the two commands
sudo pacman -S linux-lts linux-lts-headers
grub-mkconfig -o /boot/grub/grub.cfg

Then I will shutdown, remove USB-stick, check BIOS and reboot.

I hope it will work. Thanks.

I see now sdb1 and 2, not sure what this is. I will ignore so far.

image

Okay, everything seems to work now. Great and thanks for perfect support.
Even the sound via HDMI is now available again.

I also activated now the first line in picture below, but then the boot menu after reboot shows to me only LTS to choose. How to switch from LTS to mainline in case of a reboot (without deactivating the first two lines)?

grafik

1 Like

You need to install both linux and linux-header to also have mainline kernel displayed at boot and installed alongside lts. Glad that audio works now, congrats!

Understood. I am only surprised because I activated now mainline and LTS (both with headers) but during boot it only shows LTS (see pictures, sorry one is not really sharp).

grafik

grafik

That’s why I prefer command line… Try

grub-mkconfig -o /boot/grub/grub.cfg

And reboot.

Great, now it shows mainline and LTS (default) during boot. Thanks.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.