No root login to tty - default install

Hi community,

i think my problem is because i’m inexperienced with endeavouros. I installed a fresh system. I noticed that sudo is active. It works so far correct. But i can not login at the tty shell on console with root. I renew the password for root to be sure I use the right one. I also controlled if there are keyboard problems but no.
I searched the forum and the internet how to activate root login but nothing worked.

What did endeavouros.configured to deactivated root login?


EDIT: Only root account cant login. I also can use su with normal user and it worked. I have nothing configured additionally. Its really a fresh installation. I will also mentioned the error message in the tty console: “Login Incorrect”

We do not disable the root login.

Make sure it isn’t locked out with sudo faillock

Show all accounts valid.

If you can use su and it works it may be an issue with your keyboard layout in the TTY.

no, i mentioned it in the first post. my normal user has the same password as root for simpler installation at the moment. This user can login without problems.

Just to make sure we are using the same language, how are you accessing the TTY to test this?

with Strg+Alt+F2 to 6 from the gui screen

Don’t know exactly what you mean by Strg, but the key combination should typically be

Ctrl-Alt-F2 ... Ctrl-Alt-F6

Note that the combination can be limited.

sorry…for german layout is Ctrl = Strg. :wink:

1 Like

Have you tried to simply write the password keys on the TTY?
This way you can see that the keys are the same on TTY and normal terminal.

Yes I did. They are correct.

Ok, that was just a simple check.
Another simple check: if you temporarily change the root password to something very easy, does that work with the TTY?

No, I use “1234”. Same error.

Does su -l work?


I checked the passwd and noticed that as shell for root the entry is /usr/bin/bash. So i changed it to /bin/bash and the login works. I didnt changed that entry. My system was hacked I think. Really disturbing.

/usr/bin/bash is exactly the same file as /bin/bash.
So that shouldn’t have been the problem.

/usr/bin/bash isn’t in /etc/shells so it isn’t considered a valid shell even though it is the same file.

That’s interestingly true and explains it.

The culprit seems to be why and who changed /etc/passwd.

meanwhile i installed a fresh EOS as VM and the same problem occurs. I changed /usr/bin/bash to /bin/bash and it works.
I think dalto explains it correct. /usr/bin/bash is missing in the /etc/shells. But my question is why is /usr/bin/bash set as shell to user root. The other users get /bin/bash.