No .pacnew file in pacman.d

I may have deleted the .pacnew file last week
And today I notice that with the pacman migration to github completed there are some instructions to follow that require the .pacnew file
When I try to follow those instructions I get this

Is there anyway to re-download the .pacnew file? I have tried -Syyu

In “pacman>=6.0.2-7” the >=6.0.2-7 is not part of the package name. It is just short hand for saying pacman needs to be greater than or equal to version 6.0.2-7

To see the current pacman version

pacman -Q pacman
pacman 6.0.2-6

pacman -Q does not require sudo
pacman -S does require sudo

I am waiting untill Monday or perhaps Tuesday before messing with this to let the mirrors refresh.



yeah I get
I’m thinking I just comment out the [Community] section from my exiting pacman.conf file in the /etc dir since [Community] is merged with [Extra].

Here is the PKGBUILD for pacman

Notice the version is 6.0.2-7


Wait until the next update you perform that includes pacman-6.0.2-7 and it should notify you of the .pacnew file.

Then in the Welcome screen under the Assistant tab, I intend to use “Pacdiff & meld” to tend to the .pacnew file.


Looks like you don’t have the updated pacman package yet. What i did is update my mirrors first and then ran an update.

This isnt an urgent change. Just wait until the new pacman hits your mirror.

I was just looking at the arch repo for pacman and grabbed the .zst file (download from mirror) so I’ll use that instead.
but thanks again

I updated the endeavour mirrors from the welcome app and now I’m getting this

It looks like you loaded something other than a morrolist file.

Nevermind, fixed it. Downloaded the mirrorlist from github

yeah it looks to be a html file. I deleted it and grabbed the endeavouros-mirrolist fromthe github repo
all good now, cheers.

1 Like

I saw this trick on the manjaro forum a long while ago

meld admin:///etc/pacman.conf admin:///etc/pacman.conf.pacnew

Just to be clear, it is the pacman.conf in /etc that will need melding with the pacman.conf.pacnew file in /etc. I am not sure where the /etc/pacman.d/mirrorlist file came into the equation.

The actual changes are here:

1 Like

Yes you’re right, I’ve edited my previous post to show that.
Also after updating pacman to 6.0.2-7 I rebooted and updated and it provided the pacman.conf.pacnew file that I thought I was missing. The new file removes [Community] as that got merged with [extra]