No internet when booting from USB/When trying to install

I’m moving over from Manjaro, and I’m trying to install from a USB, but it shows no internet connections. Not even that I have a wifi dongle plugged in. For reference, I have a Netgear A6210 adapter. What do I need to do to fix or find out what the issue is? The reason I want to install via internet is because I prefer to use KDE.

With the USB plugged in run

lsusb

Paste the output from the terminal. (Select the output and click </>)

Typing lsusb in the terminal outputs:

Bus006 Device 001:ID 1d6b:0003 Linux Foundation 3.0 root hub

It then just stops and hangs there, and does nothing else.

One thing to note is that whenever I try restarting out of the live USB, this:

mt76x2u 5-2:10 vendor request failed

Is constantly outputted to the black screen, and does this until I unplug my wifi dongle, in which my PC then restarts.

Well , installing offline and coverting to KDE is viable option

My tip if you want to do the net install is to tether internet on your phone while doing that and then download the wifi driver from the AUR.

1 Like

I actually never thought to do this, I’ll go try it out and see if it works. Thank you!

1 Like

mediatek - can be a pain.

https://bbs.archlinux.org/viewtopic.php?pid=1871436#p1871436 (tagged with solved)

Think I might be out of luck, unfortunately. I’ve tried installing the linux adapter drivers and it has failed each time. I’ve also tried what Aarhus suggested and it didn’t recognize my adapter at all. In the case that this issue can’t be solved, could any of you recommend some good wifi adapters/dongles that work with linux perfectly? Thank you all for trying to help me, though.

Thought I was smart - I have a couple of these - but they work now (driver package at https://uex.dk/public/archive/Packages)

  • Ralink Technology, Corp. MT7610U (Archer T2U 2.4G+5G WLAN USB)

Must be firmware 1.x to work with Linux (a very good adapter - can be really hard to come by - for the same reason)

  • Qualcomm Atheros Communications AR9271 802.11n

Or check at amazon