No internet on Broadcom BCM4352

Show rfkill list all

After installing broadcom-wl or broadcom-wl-dkms, remember to install linux-headers package too.

I guess you should try creating a blacklist file.

sudo nano /etc/modprobe.d/blacklist.conf

Put the following inside.

blacklist b43
blacklist b43legacy
blacklist bcm43xx
blacklist bcma
blacklist brcm80211
blacklist brcmfmac
blacklist brcmsmac
blacklist ssb

Then ctrl o enter to save
Then ctrl x to exit.

Edit: Then reboot and see

You may also need to run depmod -a
So try that and i will leave you with this info to look over. I’m not sure why it’s not working it should be. I have a number of broadcom wireless adapters and have no issue with them.


You can use the following command and see if it is using any module.

lspci -nnk | grep -iA2 net

Edit: You could also check ip link

I assume it’s using NetworkManager. Maybe also try.

systemctl stop NetworkManager

systemctl enable NetworkManager

systemctl start NetworkManager

Also are you currently connected via network? If you click on the network icon it doesn’t show any wireless.

Okay I have looked up the BCM4352 with [14e4:43b1] (rev 03) ID and it has no support showing on the linux wireless page. But i also see both bcma and wl as kernel modules and it has the wl module loaded. It either has to work on the bcmwl-kernel-source module according to the info i can find or wl.
We blacklisted bcma in the /etc/modprobe.d/blacklist
So i guess your going to have to try unblacklisting it. Then if that doesn’t work try adding wl to the black list.

Other than that I’m out of ideas. Sorry.

1 Like

That is a kernel parameter that you could try. Are you saying the wifi is showing there but it just won’t connect? Or is there no wifi?

What is the output of pacman -Q broadcom-wl currently for you?

Are you able to install broadcom-wl?

sudo pacman -S broadcom-wl

it asks me if i want to uninstall the dkms version. I did this and it uninstalled both the wl and the wl-dkms. Then i tried to connect and it just worked. Thanks a lot for the help guys!!! Do think we tried this earlier to, so it might have been some of the things we did later that fixed it. Thanks alot anyways!!