No Fan Speed output with HP Elitebook 845 G10

Hi there,

I recently got my new laptop - the HP Elitebook 845 G10 - running with latest Endeavour OS with Gnome. (Never had a better uncomplicated installation and everything running out of the box. 100% recommended buy for Linux in case you’re looking for a new one…)

Just a minimini-issue is that there’s “No data” displayed in the “Vitals” extension.

inxy -Fxz

returns

System:
  Kernel: 6.1.71-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    Desktop: GNOME v: 45.3 Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Laptop System: HP product: HP EliteBook 845 14 inch G10 Notebook PC
    v: SBKPF serial: <superuser required>
  Mobo: HP model: 8B6E v: KBC Version 60.28.00 serial: <superuser required>
    UEFI: HP v: 82 Ver. 01.03.09 date: 12/11/2023
Battery:
  ID-1: BAT0 charge: 51.1 Wh (99.8%) condition: 51.2/51.3 Wh (99.8%)
    volts: 13.0 min: 11.6 model: Hewlett-Packard Primary status: not charging
CPU:
  Info: 8-core model: AMD Ryzen 7 7840U w/ Radeon 780M Graphics bits: 64
    type: MT MCP arch: Zen 4 rev: 1 cache: L1: 512 KiB L2: 8 MiB L3: 16 MiB
  Speed (MHz): avg: 2172 high: 4692 min/max: 1600/6677 boost: enabled cores:
    1: 1600 2: 1600 3: 1876 4: 1609 5: 4692 6: 1600 7: 1876 8: 1600 9: 3300
    10: 1876 11: 3300 12: 1600 13: 1876 14: 1600 15: 1459 16: 3300
    bogomips: 105442
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: AMD Phoenix1 vendor: Hewlett-Packard driver: amdgpu v: kernel
    arch: RDNA-3 bus-ID: c3:00.0 temp: 45.0 C
  Device-2: Quanta HP 5MP Camera driver: uvcvideo type: USB bus-ID: 3-1:2
  Device-3: Creative Live! Cam Sync 1080p V2 driver: snd-usb-audio,uvcvideo
    type: USB bus-ID: 7-1.2:4
  Display: wayland server: X.Org v: 23.2.3 with: Xwayland v: 23.2.3
    compositor: gnome-shell driver: gpu: amdgpu resolution: 3840x1600~60Hz
  API: EGL v: 1.5 drivers: kms_swrast,radeonsi,swrast platforms:
    active: gbm,wayland,x11,surfaceless,device inactive: N/A
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.2-arch1.2
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
    gfx1103_r1 LLVM 16.0.6 DRM 3.49 6.1.71-1-lts)
Audio:
  Device-1: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: c3:00.1
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
    driver: snd_pci_ps v: kernel bus-ID: c3:00.5
  Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: c3:00.6
  Device-4: GN Netcom Jabra Engage 75 driver: jabra,snd-usb-audio,usbhid
    type: USB bus-ID: 7-1.1.3:5
  Device-5: Creative Live! Cam Sync 1080p V2 driver: snd-usb-audio,uvcvideo
    type: USB bus-ID: 7-1.2:4
  API: ALSA v: k6.1.71-1-lts status: kernel-api
  Server-1: PipeWire v: 1.0.0 status: active
Network:
  Device-1: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e v: kernel bus-ID: 01:00.0
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
    bus-ID: 8-1.6:3
  IF: enp197s0f4u1u6 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB
    bus-ID: 1-3:2
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
Drives:
  Local Storage: total: 931.51 GiB used: 339.25 GiB (36.4%)
  ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P5PSSD8 size: 931.51 GiB
    temp: 35.9 C
Partition:
  ID-1: / size: 914.84 GiB used: 338.96 GiB (37.1%) fs: ext4 dev: /dev/dm-0
    mapped: luks-a9da828d-25f9-493d-b861-fd0781f47ea7
Swap:
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) file: /swapfile
Sensors:
  System Temperatures: cpu: 49.9 C mobo: N/A gpu: amdgpu temp: 46.0 C
  Fan Speeds (rpm): N/A
Info:
  Processes: 396 Uptime: 21h 53m Memory: total: 32 GiB note: est.
  available: 30.64 GiB used: 4.82 GiB (15.7%) Init: systemd Compilers:
  gcc: 13.2.1 clang: 16.0.6 Packages: 1206 Shell: Zsh v: 5.9 inxi: 3.3.31

relevant part:

Sensors:
  System Temperatures: cpu: 49.9 C mobo: N/A gpu: amdgpu temp: 46.0 C
  Fan Speeds (rpm): N/A

I ran sudo sensors-detect' and got a /etc/sensors3.conf` with a section like

chip "fschds-*"
# Fujitsu Technology Solutions, "Hades"-Chip

# Temperatures
    label temp1 "CPU Temp"
    label temp2 "Super I/O Temp"
    label temp3 "System Temp"

# Fans
    label fan1 "PSU Fan"
    label fan2 "CPU Fan"
    label fan3 "System FAN2"
    label fan4 "System FAN3"
    label fan5 "System FAN4"

# Voltages
    label in0 "+12V"
    label in1 "+5V"
    label in2 "Vbat"

chip "fscsyl-*"
# Fujitsu Technology Solutions, "Syleus"-Chip

# Temperatures
    label temp1 "CPU Temp"
    label temp4 "Super I/O Temp"
    label temp5 "Northbridge Temp"

# Fans
    label fan1 "CPU Fan"
    label fan2 "System FAN2"
    label fan3 "System FAN3"
    label fan4 "System FAN4"
    label fan7 "PSU Fan"

# Voltages
    label in0 "+12V"
    label in1 "+5V"
    label in2 "Vbat"
    label in3 "+3.3V"
    label in5 "+3.3V-Aux"

Do you have any idea why I have no data there?

Thanks for ideas and hints :wink:

have you tried with the regular Kernel? Newest hardware usually needs the newest kernels. LTS will update to 6.6 anyway in the next days/weeks - that change is already in testing and the regular kernel will update to 6.7.

However, it could simply be that Fan speed reporting is not implemented yet for your specific model - I am definitely no expert on that field, on my Lenovo Thinkpad E495 it just worked out of the box.

1 Like

Good idea. I have a newer kernel in place. I’ll try this. If okay I will just wait for the LTS to upgrade to 6.6 in the next days.

the new LTS just got promoted to stable.
Regular kernel is not updated to 6.7 in any branch yet.

1 Like

Can confirm, just checked, same results. 845 G10 running latest Endeavour, although I use the regular kernel. Tested on Zen just for kicks as well, no difference.

Agree with your opinion overall, I had a G9 and hated it, but really liking the G10 so far. Great performance, and incredibly slim and light for a business system that still has 2 SODIMM slots and takes a 2280 SSD.

1 Like

A lot of modern laptops just either do not have sensors or do not make them available to be read, my Lenovo is exactly the same.

1 Like

No luck with 6.6.10 LTS - out right now.
May be with 6.7.+

No worries, all good as it’s just a micro issue. Thanks for confirming @tlmiller76

I’ve had the same thing on my Lenovo x1 carbon gen7. However, when I was running vanilla Arch, motherboard’s temperature and fan speed were available. That’s odd behaviour because EndeavourOS is pretty much the same distro.

I couldn’t figure it out, but could it be related with Dracut omitting any kernel modules when generating images?

I might check again with an Ubuntu I have on an external SSD. But good hint with kernel modules.

That should not be caused by dracut behaving differently, because dracut only provides stuff for very early boot (the initramfs), it does not prevent stuff from being loaded after the initramfs is completely loaded (most stuff is loaded afterwards, anyway)

1 Like