No default controller available in bluetooth (not working on kernel 6.9)

As in the title, the problem is happening using kernel 6.9 but not with 6.6 LTS.

I have tried most of the things suggested in other post in both EOS-forum and ArchWiki.

I have also tried to unplug the power for about 1 minute, but did not fix the problem.

Following are the outputs of multiple commands:

$ uname -r
6.9.1-arch1-1
$ rfkill list all
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
$ systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset: disabled)
     Active: active (running) since Sat 2024-05-18 17:03:53 JST; 17min ago
       Docs: man:bluetoothd(8)
   Main PID: 556 (bluetoothd)
     Status: "Running
      Tasks: 1 (limit: 28725)
     Memory: 2.0M (peak: 2.8M)
        CPU: 22ms
     CGroup: /system.slice/bluetooth.service
             └─556 /usr/lib/bluetooth/bluetoothd

 5月 18 17:03:53 hx90gnome systemd[1]: Starting Bluetooth service...
 5月 18 17:03:53 hx90gnome bluetoothd[556]: Bluetooth daemon 5.75
 5月 18 17:03:53 hx90gnome bluetoothd[556]: Starting SDP server
 5月 18 17:03:53 hx90gnome systemd[1]: Started Bluetooth service.
 5月 18 17:03:53 hx90gnome bluetoothd[556]: Bluetooth management interface 1.22 initialized
$ lspci -k
...
03:00.0 Network controller: MEDIATEK Corp. MT7921K (RZ608) Wi-Fi 6E 80MHz
	Subsystem: MEDIATEK Corp. MT7921K (RZ608) Wi-Fi 6E 80MHz
	Kernel driver in use: mt7921e
	Kernel modules: mt7921e
...
sudo dmesg | grep -e mt7921e -e btusb
[    2.496358] usbcore: registered new interface driver btusb
[    2.500087] mt7921e 0000:03:00.0: enabling device (0000 -> 0002)
[    2.506648] mt7921e 0000:03:00.0: ASIC revision: 79610010
[    2.583743] mt7921e 0000:03:00.0: HW/SW Version: 0x8a108a10, Build Time: 20240219110958a
[    2.844961] mt7921e 0000:03:00.0: WM Firmware Version: ____010000, Build Time: 20240219111038
$ lsmod | grep -e mt7921e -e btusb
mt7921e                24576  0
mt7921_common          90112  1 mt7921e
btusb                  86016  0
mt792x_lib             73728  2 mt7921e,mt7921_common
btrtl                  32768  1 btusb
mt76_connac_lib       102400  3 mt792x_lib,mt7921e,mt7921_common
btintel                65536  1 btusb
mt76                  139264  4 mt792x_lib,mt7921e,mt7921_common,mt76_connac_lib
btbcm                  24576  1 btusb
btmtk                  12288  1 btusb
bluetooth            1122304  15 btrtl,btmtk,btintel,btbcm,bnep,btusb

I can see that dmesg | grep -e mt7921e -e btusb does not say anything about the mt7921e being initialized…could that be the problem?

Thanks a lot for your help

The daemons for the bluetooth protocol stack - bluez and related packages have been updated in the Arch repos. Have you also updated those packages?

I have the same issue after updating to 6.9.1 and it seems to be the same adapter. I have completely updated my system including the bluetooth packages. I also had the LTS kernel on the system and it works when I switch to that kernel, even after the newest update of the LTS kernel.

I just found this on the arch forums
https://bbs.archlinux.org/viewtopic.php?id=295908

There seems to be a wrongly named driverfile. Hopefully it will be fixed soon.

4 Likes

I’m also having bluetooth issues, i have done the following

restarted bluetooth with systemctl, bluetooth icon shows with it innactive, i turn it on and it vanishes

Had the same issue, this symlink and a restart fixed it for me for now:
https://bbs.archlinux.org/viewtopic.php?id=295965

2 Likes

Welcome to the purple side @BlizzToast :enos_flag:

1 Like

Do you enable the service with sudo systemctl enable bluetooth.service and sudo systemctl start bluetooth.service

Yes, it worked for close to a year before changing to this kernel and it works on the LTS kernel without making changes. They just made a mistake with the driver which now isn’t loaded properly in the newer kernel.

Yes, but it did not solve the problem.

I also suspected it was a problem related to loading the driver.
I guess I just need to wait for a fix in upcoming kernel point releases.

Yes, let’s hope it’s soon.

1 Like

It’s fixed now for me after updating to kernel 6.9.2.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.