No chance to run endeavourOS

Hi,

today i had to reinstall Windows 10. I created a partition for it and installed it. After that i installed EnOS. But there is an error at 19%

External command finished with errors Code 127 and something about systemd.

I tried online version of Installation.

Offline Installation succeeded but i can’t update my system.

And restart offers grub rescue.

Might be mirrors, if so, please update mirrors before installing.
If the problem comtinues, you could send the install log with the terminal before rebooting:

cat $HOME/endeavour-install.log | eos-sendlog

and show the resulting URL here.

Sudo pacman -Syy under liveuser and then install online version. Your command make an error

Bash: eos-sendlog: command not found

Which ISO version are you using?
You should download the latest.

liveuser@eos-2020.05.08

I will try the latest one.

New problem when i try to install popsicle-git to create a bootable usb thumbdrive:

error: rust: signature from "Jan Alexander Steffens (heftig) <heftig@archlinux.org>" is unknown trust :: File /var/cache/pacman/pkg/rust-1:1.51.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

Can you use dd to burn the USB?
https://discovery.endeavouros.com/installation/create-install-media-usb-key

Unfortunately, not. System freezes when the usb drive is almost finished.

looks like a defective usb? can you try another usb drive, they are notoriously unreliable.

Have only this drive. Alternative would be a dvdrw drive

Did you try the non git version of posicle>

yay -S popsicle

Doesn’t work either. Get the same error

Fehler: rust: signature from "Jan Alexander Steffens (heftig) <heftig@archlinux.org>" is unknown trust

google-ing the error i came to this solution: https://dev.to/mattdark/signature-is-unknown-trust-arch-linux-on-vbox-3452

sudo rm -r /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate archlinux 
sudo pacman-key --refresh-keys
sudo pacman -Sy gnupg archlinux-keyring 
sudo pacman -Sc

try this and see if you get further.

Now its working but after Installation there is no internet connection.

What is your network card or are you using wifi?

inxi -n

Using LAN. Driver: r8169.

So it’s not working?

1 Like

Doesn’t work. Seems r8169 has no driver installed.

Hit me, now there is an internet connection… Not my day

@Endlich
Did you try this?

I uninstalled r8168, rebooted and there was no connection to the internet.

Then i shutdown my computer, started it again and et voíla internet is back…

Don’t ask me why or what, but linux hates me i guess. :rofl:

2 Likes