No boot after graphic driver installation

I installed a driver for my nvidia, then a tool that allows to switch gpu, since my pc does not boot anymore, there is no error but at the time of launching KDE it did not boot.

unfortunately this tells us nothing? what tool did you install for switching gpu? what nvidia card are you using? is it new? what is your CPU (11gen intel and nvidia newer cards don’t play well together always)

It was prime switcher, I managed to uninstall it in safe mode, my pc boots well but once on the login page of endeavouros, I enter my password, impossible to launch the DE, I return indefinitely on the login page.

I have a ryzen 5 4000 series and a gtx 1650

Can you boot to TTY by pressing Ctrl-Alt-F3 (or another Fx-key)?
If so, then please run the following terminal commands to send us more info:

inxi -Fza | eos-sendlog
cat /var/log/Xorg.0.log | eos-sendlog

and show the returned addresses here.

If TTY does not work, boot with the USB installer, arch-chroot to your system, and run those commands above.
You’ll find info about arch-chroot in our wiki.


Did you get those from TTY or the USB installer?

No, I did it through the console mode on the login page


Isn’t prime-switcher only supposed to work with NVIDIA and Intel hybrid graphics? The system has NVIDIA and AMD.

This means that graphics are OK.
Your user account session has the problem.

The journal should contain useful troubleshooting messages.

journalctl --user -b

Since you can login from TTY, try starting your Desktop Environment from the console.
For KDE, try

export DESKTOP_SESSION=plasma

If it fails, post a screenshot of the TTY messages.

$Display is not set or cannot connect to the X server

Check your display manager:

systemctl status display-manager

You may have remaining conf files for xorg. Check

ls -l /etc/X11/xorg.conf.d/

Except from a keyboard file, nothing else should be there by default, unless you or a utility created them.

API: OpenGL Message: GL data unavailable in console for root

How did you end up with lightdm? KDE uses SDDM

You should have said that you logged in TTY as root.
You should not start a graphical session as root.
Did you try to login as your normal user? If not, try it and if successful, try to start plasma as suggested.

Even when I log in to the user, I get a display error when I try to launch the GUI

Why don’t you disable lightdm and install and enable sddm for KDE. Then try launching the desktop environment.

1 Like