No audio since Pulsemeeter installation

Hi all!

I’ve installed EndeavourOS and am currently running into a sound issue.

I have a Intel I7-8700K, a NVidia GTX 1080 and 32 GB of RAM (DDR4).

I’m using my motherboard’s audio jack to plug a small audio system and using USB to connect a preamp which powers my headphones.

With both devices, I get no sound and it seems that Youtube refuses to play any videos because of this (I’ve tried Youtube with Konqueror and Firefox, same result).

I had a Mint Cinnamon OS previously and it worked flawlessly, but since I’ve been on Endeavour, no luck… I played a bit with the audio configs trying to install Pulsemeeter (still no luck with it, always getting an error when starting it), but I’m not sure if I’ve broke something. I’ve installed pulseaudio, which, I think, can cause problems with pipewire.

Here’s the output of inxi -xxA:

  Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel bus-ID: 1-9:5 v: kernel chip-ID: 046d:0a5b
    bus-ID: 00:1f.3 chip-ID: 8086:a2f0
  Device-2: NVIDIA GP104 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f0
  Device-3: Logitech G933 Wireless Headset Dongle type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-4: C-Media Hifi Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 2-2:2 chip-ID: 0d8c:0158
  API: ALSA v: k6.2.9-arch1-1 status: kernel-api
  Server-1: PipeWire v: 0.3.67 status: active with: 1: wireplumber
    status: active 2: pipewire-alsa type: plugin 3: pw-jack type: plugin
  Server-2: PulseAudio v: 16.1 status: active

In the audio menu, the selected output is my preamp, which worked yesterday with Mint.
Anyone has any idea how I could fix this?

P.S.: If someone also knows how to install PuleMeeter or knows a nice alternative, I would really appreciate if you let me know :slight_smile:

You can’t have both, but have to decide for either one.


With your setup, I’d first stick with pulseaudio, although pipewire might be viable as well, or even better, if you give it a try… :v:

1 Like

I’ve tried the PulseAudio solution you’ve linked, but when I run sudo pacman -R pipewire wireplumber libwireplumber gst-plugin-pipewire as proposed on the site, it gives me this error:

error: failed to prepare transaction (could not satisfy dependencies)
:: removing pipewire breaks dependency 'pipewire' required by kpipewire
:: removing wireplumber breaks dependency 'pipewire-session-manager' required by kwin
:: removing pipewire breaks dependency 'pipewire' required by pipewire-audio
:: removing pipewire breaks dependency 'pipewire' required by xdg-desktop-portal

I have similar dependecies when trying to install only pipewire…

So you have to remove pipewire completely, first. (see instructions in EnOS Wiki above). Maybe, you also need to remove pulseuadio, too.
Then reboot and re-install either one. :v:

1 Like

You’re proposing I run sudo pacman -Rc pipewire to remove all dependencies with pipewire? It seems a bit risky, but since I’m new here, I could make sense that my inexperience is tricking me.

I see now. The KDE dependencies shouldn’t be removed, if Plasma is your DE. So try uninstalling pulseaudio completely and reinstall pipewire completely… don’t forget to reboot and see how it works from there. Your pulsemeeter probably won’t work then. You might have to look for an alternative there.
Pavucontrol (Pulse Audio Volume Control) will still be there with pipewire and without polseaudio. In pavucontrol, you can configure your audio sinks under the config-tab, upper right corner… >



Wow, it started working as soon as I uninstalled Pulseaudio.

Many thanks! :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.