No Audio, but not sure since when

I noticed today when trying to play an mp3 file that I had no audio on my laptop. Going into the volume settings shows the blue bar moving as if sound should be playing, but all I have is silence. I have tried looking through the forums here, but I still am not sure what the problem is. To make things worse, I tend to keep my laptop volume muted most of the time, so I do not know when it stopped working for sure.

I already tried using different kernels including zen, lts, and normal. It does not work in any of them. I did see something about laptops with dual gpus (intel and nvidia dedicated for instance) were having some bug or issue. I have this kind of setup in my laptop. I am supposed to run music from my laptop this Friday for an event at my kids’ school, but I am thinking I might need to use my tablet instead of my laptop if I cannot get this figured out.

I am more than happy to provide any and all system information that might help. I also have not messed with anything in the audio settings, so I don’t think it is something I did haphazardly. I know it could be related to an update of something that I did, but since I do not know for sure when it stopped working, I am not sure where to even begin to look.

As always, I appreciate any help and advice. This community is amazing and I am really hopeful that one day I will be able to be one of the people helping to answer questions like these instead of always being the one asking them… Thanks in advance!

Hi, could you provide more info about your system by posting the link generated with

inxi -Fxxc0z | eos-sendlog

Do you hear any audio when executing

speaker-test -l1

and no, no sound… :frowning:

could you also provide

aplay -lL | eos-sendlog

and check the mighty pavucontrol config tab:
could be set of (Aus) …
And check alsamixer:
alsamixer and press F6 to select your device (could be a channel is muted):

try removing user specific configs:

rm -R ~/.config/pulse ~/.local/state/{pipewire,wireplumber}

(will give an error if only one exists wireplumber or pipewire but ignore that)

and re-login or reboot the system completely…

aplay -lL |eos-sendlog -

Here is what my pavucontrol looks like (see pic).

And here is my alsamixer (see pic).


speaker-test -Dsysdefault:PCH -l1

pavucontrol needs to be closed and no other applications playing audio

1 Like

configuration tab is the interesting one :wink:

But looks like Speakers aren’t muted and chosen…

Are you sure ether is no hardware volume switch? on keyboard?

I had a problem with this yesterday following an update. Just like you, the problem persisted across all kernels. The problem manifested as video streams and spotify songs refusing to load, so it took a while to isolate it to my speakers not working lol.

The issue was resolved by installing the pipewire-pulse package (which also uninstalls pulseaudio). Following a restart, audio functioned just fine.

EndeavourOS switched to pipewire a while ago. Looking at revm’s posts I assume he installed EndeavourOS recently. As long as he used a recent iso he should already have pipewire and not pulseaudio.

When is “a while ago”? My install is fairly recent (March/April this year, I think) and I was using pulseaudio (this was the default configuration).

With the Atlantis release in December 2021.

1 Like

inxi -Aa
will show what you are using …

gives me this:

[revm@rev-x705udr ~]$ inxi -Aa
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
    bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
  Sound API: ALSA v: k5.19.13-zen1-1-zen running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes

So my current install definitely post-dates that. It is very weird that I was using pulseaudio as my driver but also unsurprising that it did not work very well.

Check if you really use pulseaudio on pipewire :

pactl info|grep 'Server Name'
Server Name: PulseAudio (on PipeWire 0.3.59)

Would it be worth reinstalling PipeWire? And if so, what is the best way to do that? Like, should I clear out any dot files or config files the system makes when you install it the first time?

It looks good to me, the only thing you didn’t check is the settings in pavucontrol configuration tab.

Whoops. Sorry about that. This is all I see on the configuration tab in pavucontrol.