No Audio After Install

Hello!

So I recently installed EndeavourOS on my laptop and cannot seem to get the built-in speakers working. I tried doing the offline and online install, and got the same issue with both. The speakers do work in Windows and they also work on my vanilla Arch install. Headphones work when plugged in. Pulse audio and alsa recognize the speakers, just no audio coming out.

The laptop is an MSI GL63 9SDK
i7 9750H
GTX 1660 TI (switches between intel integrated and nvidia)

Any ideas?

Welcome!

Maybe the speaker audio volume is set to 0?

Don’t think it is
image

Then do changes under the Configuration tab help?

I’ve tried all the available options under configuration

OK.
As I’m no audio expert here, I hope others here with better audio experience can help you more.

Hello @Comixs
Did you look at the alsamixer settings.

It looks right and i think that is the right audio chip? Realtek ALC120

speaker-test -c 2

If I see right, the Volume Control picture shows the speaker is muted?

I think MM is muted?

Cltr z to stop it. Did you get any sound?

Ctrl-C stops it…
Ctrl-Z only suspends it.

No sound from it

Oh …i tried C and it didn’t seem to work but maybe it wasn’t finished.

@ricklinux
Use command fg to get it back from suspend.

Did you try reset pulseaudio -k

Already tried it

What about alsactl restore