No access to any tty from desktop

So I have been using EOS for a couple of years. I don’t know if this is a wayland issue or an EOS issue. I can’t switch to a TTY in the event I need to. I have searched all over the forums and even the arch wiki to no avail.

how do I enable TTY access if my desktop freezes for some reason?

Here is my inxi -FAZ info.

System:
  Kernel: 6.9.3-arch1-1 arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.5 Distro: EndeavourOS
Machine:
  Type: Laptop System: LENOVO product: 82SG v: IdeaPad 5 15ABA7
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76463WIN
    serial: <superuser required> UEFI: LENOVO v: KACN20WW date: 12/08/2022
Battery:
  ID-1: BAT0 charge: 39.0 Wh (69.6%) condition: 56.0/57.0 Wh (98.3%)
CPU:
  Info: 8-core model: AMD Ryzen 7 5825U with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 589 min/max: 400/4546 cores: 1: 400 2: 400 3: 400 4: 400
    5: 400 6: 400 7: 400 8: 1432 9: 1397 10: 400 11: 400 12: 400 13: 400 14: 400
    15: 400 16: 1397
Graphics:
  Device-1: AMD Barcelo driver: amdgpu v: kernel
  Device-2: Chicony Integrated RGB Camera driver: uvcvideo type: USB
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
    dri: radeonsi gpu: amdgpu resolution: 1536x864
  API: EGL v: 1.5 drivers: radeonsi,swrast
    platforms: wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.1.1-arch1.1
    renderer: AMD Radeon Graphics (radeonsi renoir LLVM 17.0.6 DRM 3.57
    6.9.3-arch1-1)
  API: Vulkan v: 1.3.279 drivers: radv surfaces: xcb,xlib,wayland
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  API: ALSA v: k6.9.3-arch1-1 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active
Network:
  Device-1: Realtek RTL8852BE PCIe 802.11ax Wireless Network
    driver: rtw89_8852be
  IF: wlan0 state: up mac: b8:1e:a4:5b:99:f9
Bluetooth:
  Device-1: Realtek Bluetooth Radio driver: btusb type: USB
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: disabled
    rfk-block: hardware: no software: yes address: N/A
Drives:
  Local Storage: total: 476.94 GiB used: 43.59 GiB (9.1%)
  ID-1: /dev/nvme0n1 vendor: Micron model: MTFDKCD512TFK size: 476.94 GiB
Partition:
  ID-1: / size: 461.11 GiB used: 43.58 GiB (9.5%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 998 MiB used: 6.4 MiB (0.6%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 461.11 GiB used: 43.58 GiB (9.5%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-4: /var/log size: 461.11 GiB used: 43.58 GiB (9.5%) fs: btrfs
    dev: /dev/nvme0n1p2
Swap:
  ID-1: swap-1 type: partition size: 14.85 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p3
Sensors:
  System Temperatures: cpu: 41.4 C mobo: N/A gpu: amdgpu temp: 40.0 C
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB note: est. available: 13.5 GiB used: 2.46 GiB (18.3%)
  Processes: 302 Uptime: 36m Shell: Bash inxi: 3.3.34

Edit to add: This has been an issue on 2 different brands of laptops.

What have you tried so far, and does your keyboard have the “Fn” key?

I’ve tried
ctrl+alt+f1 through f6
fn f1 through f6
and ctrl(or/and alt)+fn etc
with no effect.

Does it have a function lock? My Legion it is Fn+Esc.

1 Like

yes it does, that was the issue. It appears that I need the function lock enabled to be able to go to any of the TTY’s.

Thank you.