Night color in the System Tray

In the thumbnails of the main bar, the night color no longer appears. How to solve this problem?

You mean the System Tray (I edited the topic title accordingly).

In a default configuration, there is probably an arrow pointing upwards on it (or a triangle), the tooltip of which is “Show Hidden Icons”, just before the clock:


Right click on that arrow and select “Configure System Tray…”:


Under the tab Entries, find Night Color Control, and select “Always shown”:


1 Like

Hi Kresimir, i know that but nothing appears in the system tray. There is not night color control. :roll_eyes:

Perhaps reboot and see what happens? :man_shrugging:

Or just logout/login.

Hi Wordler,
I have already tried and checked but nothing is displayed despite the night color being activated in the control panel.

Do you have it enabled in System Settings?



Yes it’s enable

OK that is wierd! I wonder if the theme affects it. Which Plasma theme are you using under System Settings/Appearance?

using McMojave and for icons i’m using beautyline or arc-icons

Perhaps (temporarily) going back to default KDE Plasma theme (Breeze, including icons etc) and see what happens. This would include a reboot.

I have already tried several times but unfortunately it’s the same :cry:

Stupid question but I have to ask: when you tried default themes did you click “apply” to make the change? I apologize if this is too obvious!

yes of course

This is very strange! OK so as @Kresimir mentioned about configuring system tray did you set this up correctly and click “apply”?

yes of course

One more thing (again obvious) did you add Night Colour plasmoid to the panel from the widgets menu?
Check if this actually occurred!

no I didn’t add anything because everything worked by default before this update

So it’s an update. Can you try re-applying the plasmoid? I am updated with Plasma and I do not have this issue.

I don’t have a night color plasmoid available to add, what’s the name?

Night Colour Control. I’m not sure if it’s default or if you have to download it via the widgets menu, I can’t remember the details but it is available.