NFS mounts not working properly since plasma 6

So, I have currently almost no time for “housekeeping” on my EnOS, still some things not working as expected, the most important one is strange behavior of my NFS shares on different clients in my network (my PC, wife’s one and the one of the daughter are all affected).
My network shares are based on a TrueNAS installation, which was not changed like in years. After the change to plasma 6 my mounting does not work as before. When I try to access a mount via Dolphin, it opens the folder and then drops me back to “/” and tells me “Current location changed, ‘/Work_on_TrueNAS’ is no longer accessible.”. Second click brings me to the directory. Within the directory I have a lock symbol an every file and the directory itself, but I can access every file. But dolphin does not show any virew of the file, it looks really weird:

In the past I would have seen filepreviews as in local files and folders.

I mount the shares via the following entry within FSTAB:
truenas:/mnt/Datapool_on_TrueNAS/Work /Work_on_TrueNAS nfs x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min 0 0
This entry in my fstab came after a similar question some months ago, was a tip by @dalto :
At this point I wonder if I should just go back to CIFS, just to avoid future problems of this kind with NFS…

I am not seeing this issue on my NFS mounts. That looks like a permissions issue.

What does ls -l show the permissions to be?

I thought so, too, and checked the permissions - it looks kinda okay, I think it always looked like this:

ls -l /
drwxrwxrwx  - root     16 Nov  2023  backup
lrwxrwxrwx  - root      7 Apr 20:02  bin -> usr/bin
drwxr-xr-x  - root     14 Apr 16:31  boot
drwxr-xr-x  - root     14 Apr 16:37  dev
drwxr-xr-x  - root     14 Apr 16:38  etc
drwxr-xr-x  - root     10 Sep  2023 󱂵 home
lrwxrwxrwx  - root      7 Apr 20:02  lib -> usr/lib
lrwxrwxrwx  - root      7 Apr 20:02  lib64 -> usr/lib
drwxr-xr-x  - root     31 Jan  2023  mnt
drwxr-xr-x  - root     25 Mär 17:02  opt
dr-xr-xr-x  - root     14 Apr 16:37  proc
drwxr-x---  - root     29 Mär 15:59  root
drwxr-xr-x  - root     14 Apr 16:37  run
lrwxrwxrwx  - root      7 Apr 20:02  sbin -> usr/bin
drwxr-xr-x  - root     10 Sep  2023  srv
dr-xr-xr-x  - root     14 Apr 19:52  sys
drwxrwxrwt  - root     14 Apr 20:16  tmp
drwxr-xr-x  - root     14 Apr 16:31  usr
drwxr-xr-x  - root     14 Apr 16:37  var
drwxrwx---@ - nobody   27 Nov  2022  Work_on_TrueNAS

So, I finally had some time to dig into that, and it comes down to KDE6 - the problem is only with KDE6. Fired up a ManjaroVM with KDE5 - no issues. An Arch VM with (obv) KDE6 - issue the same as in EOS. Fedora - the same. Kubuntu on KDE5 - no issue. So I guess I have to file a bug with the KDE team, will report here. I wonder why this has not been recognized by others…

I use nfs mounts all day long and haven’t seen this issue so it must only be triggered by some very specific circumstance.

1 Like

Yeah, next up will be the testing of the two other components for the NFS stuff - server and network/firewall. Thing is: It is working fine with Plasma5, it is working fine with Windows 10 and 11 (yes, I tested THAT - somebody please shoot me), heck, I even tested with Gnome and it was working. And all of that without changing anything on my server and/or network setup.
Server is TrueNAS, with the “ordinary” NFS share setup TrueNAS has in it’s guides, so nothing special here. Router/Firewall is OPNsense, but there are no rules inside of the network in which my workstation and server are located in, so I am quite sure that these both parts of the equation are clear… Don’t know how to continue…

I think the issue is related to NFS version of TrueNAS, TrueNAS is not a rolling release. Is its NFS server compatible with current version of NFS client (rolling release)?

I have also used NFS mount with NAS (rolling release) and did not face any problem. Nevertheless, I switched to SFTP a few weeks ago for some reasons. They are not related to your issue.

1 Like

Well, I hope you’re not right here, because that would take me to the fact that there is no solution (yet) - my TrueNAS (core) is on the newest version. I will fire up a VM with TrueNAS Scale now to see if this behaves different.
Mind sharing with me which NFS server you did use? Same question goes to @dalto

Server: NFS is integrated into Arch Linux kernel LTS 6.6.30.

I am using a Synology which is unlikely to be using the latest version of anything.

Will try that out, thanks

Same with this - I have also a SynoDS available for testing.

But mentioning the Syno: dEfinately outdated NFS server, so… it should not be a too outdated NFS server here… Man, that one is difficult to tackle :frowning:

So, I guess I found the "bug:
The setting “no limit” in the preview section of dolphin settings is not available!
Main Rig, newest EndevourOS:

Kubuntus dolphin on Plasma5:
So I guess that is my root cause. Can you please chack what you guys have for settings here @Zesko and @dalto ?

Edit: Ignore this, bith have the same setting, sorry for highlighting you…

The NFS mechanism is built into any kernel, not DE.
Try going to a TTY terminal instead of KDE and browsing your TrueNAS using NFS connection, then create a new file there to see if it fails?

Did you check different kernel’s patch-versions older than the current kernel on the same client?

I notice that TrueNAS Core is based on FreeBSD. It is not the same as TrueNAS Scale based Debian Linux. Not sure if NFS server (FreeBSD) and NFS client (Linux) are compatible.

1 Like

I have no trouble whatsorever to create or manipulate files via dolphin or terminal. It is just the previews that are not working, and the strange error message that the folder is no longer accessible - which can be ignored by again clicking into the folder. So creating files is working. Creating folders is working, too.
I did not try different kernel versions, will boot into LTS to test it, but as it is just a problem of dolphin I highly doubt it is an kernel issue - will report, sir!

So, now I can delete my TrueNAS from the equation - I booted up my old Synology Diskstation, created a NFs share, and mounted it in EndevourOS - same behavior in Dolphin. Frustrating, but also helpful. Now I have to go to KDE for a bug report, I guess…

From your screenshot above, it looks like you have previews disabled. For reference, I have my max size set to 10,000 MiB.

1 Like

Yeah, you are right. will change this setting and report, but here is the thing: I never changed that setting AND it is the same in the Kubuntu VM - which gives me previews. Which seemingly renders this setting pointless. This is confusing…

Perhaps that setting was broken before and fixed now?

1 Like

Seems to be - changed that, unmounted and remounted my NFS shares, and at least I have back my previews. So for that one - thumbs up, TYVM (for like the thousands time…).
Still have to tackle the fact that Dolphin “thinks” I have no access to the folders and the error with “this resource is not available anymore” error. But we have clearly two different errors which came with Plasma6, of which one was rather a fix than an error. Still confused, but a little less. Will tinker around a bit with NFS options…

1 Like

Soooooo. after two hours of NFS shanannigans, back and forth, reading, ranting, frustration and so on I gave up. Took some sleep. Started over again by reading this topic from the start. And then it hit me like a truck. A friggin truck. There was a group not anymore available of which I was a user. Sambashare. And yes, you gave the hint in YOUR VERY FIRST POST without even knowing that - what are you for a kind of technowizard @dalto ? Too make things easier I just added my user to the group “nobody” - is there any downside to doing so? Because the files and folders belong to “nobody:nobody” after the mounting of the NFS… If there is none I will keep it, because in this way it is working.