Newly installed programs are flickering and unusable

Hello everybody, I have a problem with my newly installed EndeavourOs. I used the EndeavourOS_Artemis_nova_22_9.iso for my installation and selected xfce as my desktop environment. All pre-installed programs are working fine, but anything I install on top is behaving weird.

After the installation of the OS, I installed TimeShift and Ungoogled Chromium via yay and this is where the problems started to show.

  1. Timeshift works well most of the time, but sometimes it just quits disappears without any notice (like when restoring a snapshot it just disappears and the progress is lost).
  2. Ungoogled Chromium, as well as Chrome and Brave are basically unusable. They can be interacted with a little bit, but the apps flicker a lot and clicking does not always result in a change. Dragging the window around seems to cause a change in the otherwise frozen view.
  3. I also tried installing VS Code, which resulted in the same behaviour as 2.

Some more background information:

I installed the packages with yay -S packageName and pacman -Syu has no updates.

The only changes I did that I can remember before installing the new apps are:

  • changing the password for my user and the sudo command
  • plugging in another display (4K) and configuring the window size to x2
  • adding a Bluetooth device

Heres an example:

Problem has been solved: Intel graphics - ArchWiki ( I had to disable DRI completly.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.