New to EndeavourOS - some observations

Hello all!
A big thank you to those responible for this distro - you should use it with pride.
I have been using Linux Mint Cinnamon for the last 3 years - and for the last few months have tried many distros to see if I would like something else more.
I decided that an Arch-based rolling release would be the most interesting to run on a second desktop PC.
I had previously tried:
Debian Bullseye Cinnamon
OpenSUSE Tumbleweed
ArcoLinuxB Plasma
Archman Plasma
Manjaro KDE Testing
I am now a happy EndeavourOS Plasma user!
But there have been some bumps in the road, as expected for an Arch noobie:
1 - Calamares doesn’t always manage the partitions correctly. This happens with several distros and I have a theory: I have several old HDD’s and I install on them rather than VM’s - I find it more realistic for me. As I reuse HDD’s and I usually enable encryption, when I go to install the next distro, Calamares doesn’t like it. Even if I delete all partitions with Gparted sometimes. Often, simply not specifying a swap partition is enough to get Calamares going. I then add a swap file later. Only OpenSUSE Tumbleweed recognized encrypted HDD’s and asked for a password prior to install.
2. CUPS/printing should really be preinstalled - I notice that the online installer now provides that option.
3. DVD playback requires libdvdcss to be installed, even if VLC is installed - nowhere is this mentioned
4. Samba is not installed by default, so I couldn’t get to my linked SMB drives. I followed the wiki instructions but they did not work, as an error regarding nbsp came up. I actually copied samba.conf from another Arch distro install and that worked fine!
And that was it, not a lot of problems but some head scratching needed.
Now I love it. Very close to pure Arch without the masochism.

4 Likes

Welcome @unbeliever !
I think you’ll find, as I have, a very knowledgeable yet super friendly community here at EndeavourOS.

1 Like

Not everything has to be pre-installed (and above all nothing legally questionable).

This is more and more like a plague with many distributions. Images are getting bigger and bigger. In return, important system tools (no matter how small), running in a terminal, are left out (Ubuntu and its flavours are an example).

Especially with RRDs is even nonsensical. Just installed, the first update pulls almost everything again.

Would be just with the CUPS (and also SANE) you want (and it certainly sounds reasonable), which feels like daily alternating in their updates.

A pre-installed SAMBA wouldn’t have brought you either. You said yourself, the configuration did not fit on your system. You have to configure these things yourself for your systems. Especially samba.conf can be tricky (and graphical frontends for it can spoil the best configuration only by loading with automatic saving).

A live image is a nice thing, especially helpful for problems. However, I understand something completely different by a real netinstall image, especially something much smaller.

Actually something small, bootable, which performs the installation with a script and queries via the ncurses interface is sufficient. As it has existed before cinnearch/antergos.

1 Like

I have two Endeavour installs and both have libdvdcss installed. I didn’t install it myself but glad its there. :innocent:

After seeing this https://www.youtube.com/watch?v=AJgvIco--AU and the mention of libdvdcss, I tried playing a DVD (Skyfall) on my install.
VLC sat there looking all festive, but no James Bond.
I installed libdvdcss via pacman and tried again.
This time Daniel Craig appeared and proceeded to do his thing.
As for Samba, the command line wiki instructions did not work - I never actually got to configure Samba, so I don’t know what you mean by “the configuration did not fit on your system”.
No samba.conf was created; I copied the one from ArcoLinuxB, which worked.


is where refering too?
samba.conf is not there on a fresh install and needs to be created manually or copy over from filesystem / web or like you do another install…

@joekamprad, btw., with c&p into the editor of Wordpress and following saving you should check the result.

Signs like non-breaking space would be converted to HTML code, in this case to   (that’s very typical - therefore I use the pure editor, not the visual one, not the new one anyway). E.g. you can see that at https://endeavouros.com/docs/hardware-and-network/samba/. If the user does not pay attention, c&p in a terminal will of course not work.

i do see this also already… i will fix it now… thanks for reporting !

Ah, so that is what must have happened when I tried it.
Thank you both.

I have samba.conf work with all distro i try but with Endeavour samba didn’t work

● samba.service - Samba AD Daemon
Loaded: loaded (/usr/lib/systemd/system/samba.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Mon 2020-02-24 17:58:00 +03; 10s ago
Docs: man:samba(8)
man:samba(7)
man:smb.conf(5)
Process: 53963 ExecStart=/usr/bin/samba --foreground --no-process-group $SAMBAOPTIONS (code=exited, status=1/FAILURE)
Main PID: 53963 (code=exited, status=1/FAILURE)
Status: “daemon failed to start: Samba detected misconfigured ‘server role’ and exited. Check logs for details”
Error: 22 (Invalid argument)

فبر 24 17:58:00 wael-pc samba[53963]: root process[53963]: Copyright Andrew Tridgell and the Samba Team 1992-2019
فبر 24 17:58:00 wael-pc samba[53963]: root process[53963]: [2020/02/24 17:58:00.364468, 0] …/…/source4/smbd/server.c:742(binary_smbd_main)
فبر 24 17:58:00 wael-pc samba[53963]: root process[53963]: At this time the ‘samba’ binary should only be used for either:
فبر 24 17:58:00 wael-pc samba[53963]: root process[53963]: ‘server role = active directory domain controller’ or to access the ntvfs file server with ‘server services = +smb’ or the rpc proxy with ‘dcerpc endpoint servers = remote’
فبر 24 17:58:00 wael-pc samba[53963]: root process[53963]: You should start smbd/nmbd/winbindd instead for domain member and standalone file server tasks
فبر 24 17:58:00 wael-pc samba[53963]: root process[53963]: [2020/02/24 17:58:00.364523, 0] …/…/lib/util/become_daemon.c:121(exit_daemon)
فبر 24 17:58:00 wael-pc samba[53963]: root process[53963]: exit_daemon: daemon failed to start: Samba detected misconfigured ‘server role’ and exited. Check logs for details, error code 22
فبر 24 17:58:00 wael-pc systemd[1]: samba.service: Main process exited, code=exited, status=1/FAILURE
فبر 24 17:58:00 wael-pc systemd[1]: samba.service: Failed with result ‘exit-code’.
فبر 24 17:58:00 wael-pc systemd[1]: Failed to start Samba AD Daemon.

can you create anew topic on your issue?