New to EndeavourOS and have a couple of questions

Hi, I’m new to EndeavourOS and really liking it so far. Everything is working well for the most part. I just had a couple of questions.

  • In Firefox I heard that you can now swipe back and forth using two fingers with the touchpad. However this is not working for me. Is there something I need to do? I’m using KDE Plasma (5.26) in Wayland with Firefox (108).

  • When there are new packages available I am not receiving a notification in pamac. I’m using pamac-aur.

These are minor issues, but I’d still like to get them fixed if possible.

I know some forums don’t like multiple issues in one post and prefer each issue posted separately. If that’s the case, let’s just work on the Firefox issue for now.

Thanks :slightly_smiling_face:

I don’t use pamac, but if I’m not mistaken, you need to have pamac-tray-icon-plasma installed.

Open firefox. Go to the address bar and type about:config. Hit enter. There will be a warning asking you to proceed with caution. Click “Accept Risk and Continue.” You should be redirected to a new interface. Go to the search bar on top and search for “gesture.” You should see a list of options. Scroll down until you see the settings for gesture.swipe or something like that. Enable those settings and you should be good to go.

This is what I personally did to enable touch gestures on Firefox (GNOME Wayland):

  • Check if Firefox is running on Wayland (about:support, Ctrl+F Window Protocol). If it says xwayland, you will have to first tell Firefox to run on Wayland instead.
  • Test-launch Firefox using the Wayland (launch MOZ_ENABLE_WAYLAND=1 firefox from the terminal). Return to about:support and check if the protocol now says wayland.
  • Test the gestures (two-finger swipe, pinch to zoom) and stability (no crashes). If all goes well, we can make persisting changes. There are two solutions I have found:
  1. Using systemd to set user environment variables - you will need to run $ systemctl --user set-environment MOZ_ENABLE_WAYLAND=1, log out and log back in.
  2. Using a conditional login startup script. This is what I use because I switch between GNOME Wayland and GNOME Xorg occasionally. As per Archwiki instructions, I added this to ~/.bash_profile:
if [ "$XDG_SESSION_TYPE" == "wayland" ]; then

What happens if it still says xwayland after launching it with MOZ_ENABLE_WAYLAND=1 firefox ?

Never mind, it says wayland now. I just had to close the the xwayland browser window. And the touch gestures work now.

It said [GFX1-]: glxtest: VA-API test failed: failed to initialise VAAPI connection. in the terminal. I don’t know if that matters.

I believe it’s because hardware acceleration in Firefox is not configured yet. Setting gfx.webrender.all and media.ffmpeg.vaapi.enabled to true in about:config should solve it.

But if you have not configured system hardware acceleration yet, you will first need to do so. The instructions depend on what graphics card you have (Intel, NVIDIA, AMD).

I have not configured system hardware acceleration yet. I have both Intel and Nvidia.

I am unfortunately not knowledgeable enough to configure dual/hybrid graphics card - I have Intel UHD 620 only and followed Archwiki’s guide. But in my case it was just installing libva-utils, checking vainfo, and installing intel-media-driver which supports my card.

Sorry I cannot help much but I hope you can configure it!

The recommended way to update the system is

sudo pacman -Syu

If you have AUR packages installed, you can use command


as well.

Pamac is not recommended for updating since it hides many useful details of the updates.

To see when there are updates, you can use eos-update-notifier. But updates come very often, usually daily or even many times a day, so running the mentioned line will practically always get new updates.

Note that a cli command checkupdates will also tell if updates are available.