New install, wants a "login," but was not supposed to

This was a new install for which I requested “load right away, no password,”
but when I tried to run it, in the tiny font, it stalls with a request to “login.”
I tried my userid, two ways, and my password, but it won’t accept it.
It just hangs.

Of interest (to me anyway) is that on my first install I opted for the Xfce version (shoudnta), and it worked fine, but I didn’t like it, so I tried a new install opting for the suggested version with extra apps.
So, I do think I installed it correctly … but maybe …???

Which suggested version did you install?

1 Like

When you install the system there are a whole list of choices. The top one is suggested for those not well versed in LINUX, which I am not.
Sorry that I can’t name it now; I will have to re-install it to be able to provide full details.
It is late, and although tomorrow is Christmas, I will try to do it and get back to you.
Meanwhile, thank you for getting to me so quickly !
Merry Christmas, or whatever your faith calls for, regards, Bob T.

So you didn’t choose any desktop environment? Only the base packages selection?

The top option is just the base packages required to run the system. That means no desktop at all.

If you do an online install, you need to choose one of the desktop options or you will be left sitting at a black screen with nothing but a username prompt.

1 Like

The top one is not a suggestion for those not well versed in Linux. Generally speaking, we’re not exactly a Linux beginner stop.

If you’d like to start here, some research would do you some good. It’s a good place to start - it can be trial by fire though. It can be a tough time for an absolute beginner. On your next attempt I’d suggest giving Cinnamon a go. It’s a great starting point in my opinion. There’s a LOT to learn though.

And welcome!

Thank you all.
I had tried Xfce4-desktop. It worked, but it’s only background was various shades of blue with a mouse on it. That wasn’t so bad, but there were no apps included, and I would need at least Libre Office.

So that’s why I tried the top one, which is:-
“Base-devel + common packages”

It’s description said:-
"Recommended. Don’t change unless you know what you are doing (generic).

I am not exactly a beginner, having used MINT and Antix quite a bit, tried MX and Manaro,
but I am not well versed either, so the “generic” one seemed a good idea.

I am now trying Cinnamon.

Well you install the needed apps yourself, the installer doesn’t really provide anything else than the “bare minimum”.

There is no “extra apps” that are not in the DE base packages (you can check what the installer installs for every DE).

You have the Arch & AUR repos available to choose which applications you would like. Just choose what you need, not what other people think you should. Any dependent packages will get installed when you do this, or give you the option whilst installing them.

Hi Y’all,
Well, I installed the Cinnamon version and it worked just fine. It seems like a great OS.
So far, I am having trouble finding how to install Libre Office, or the other one … whatever it’s called.
The other Distros I’ve used have all installed Libre Office automatically, however, I agree that a whole lot of apps that you’ll never use is just a waste … time, space, confusion, etc.

Also, the other distros I’ve tried seem to have an obvious software installer/ de-installer.
I just haven’t found it in Endeavour’s apps YET … will keep trying …
unless someone tells me how.!!

There is no installer/de-installer. Go to the Arch website and click on Packages in the top left. Everything is there, and if you want more then click on AUR. Welcome to the world of Endeavour and also Arch. We can help to guide you a little but ultimately the choices you make are yours. Blue pill or Red?

To install is: sudo pacman -S (whichever app you want) in a terminal, or from the AUR yay -S (same thing). If you don’t like the app then uninstall by sudo pacman -Rsn (app).

To install libreoffice:

sudo pacman -S libreoffice-fresh
1 Like

The joy of Endeavour is that you will never have anything automatically installed. You get a starting point to build your own system. If you want libre office - you will have to install it, as virtually all other applications.

You will need to use your terminal as your installer/de-installer. There 's no “software” specifically included to do this outside of a terminal application. You may find this helpful:

EOS is a terminal centric distro. But if you prefer to use a GUI for installing/deinstalling packages you can use Manjaros Pamac.

To install it:

yay -S pamac-aur

Or, if you also want to use Flatpaks and/or Snaps:

yay -S pamac-all

I really appreciate all the help, specially this being Christmas day, although some of you are no doubt of different faiths.
AND SOOOO, I had a little trouble 'til I realized in the “call for install” the S is a capitol,
but I now have a working system WITH Libre Office.

The only inconvenience I’ve found, is that after “snoozing,” when it wakes up the mouse is a little hard to re-activate … but I may make this my “go to” system.
I have found that one can “hibernate” the system and it virtually shuts down in a couple of seconds, and wakes up quickly also … so can be pretty well left on.

Thank you all again, Bob

1 Like