New install - Correct password not working when system encrypted


This is my first EOS install :slight_smile: and I ran into a few quite strange behaviors where the correct password is not accepted in SDDM and also TTY.

1. Install

I installed EOS including KDE Plasma and LXQT and opted for the full disk encryption.

The system starts and gets to the login screen. There the password isn’t accepted (“login failure” from memory). Checked typos multiple times.

I opened a TTY (c-a-F2) and tried to log in, but this also didn’t work. So I thought I must have mistyped the password during install and installed again.

2. Install
Same setting as before (full encryption, KDE, LXQT) however this time I also clicked “automatic sign in”.

This time I made it to the desktop and everything seemed to work. I could use sudo with my user and my password.

However, when I logged out, I wasn’t able to log back in again. I tried a TTY with my user and the password did also not work.

I then logged in as root successfully. I tried to change my user password with passwd. The shell said “successful”, but I couldn’t log in as my user with the changed password.

After a restart, I then didn’t make it to the desktop, instead I got a black screen with my mouse cursor.

3. Install
I though maybe the multiple DEs cause an issue so I only chose KDE. Accidentally I also forgot to click “encrypt”.

This install works fully as intended. My user password works in TTY and graphical login.

I’m playing now with my unencrypted version of EOS and quite like it, however I will reinstall since I don’t feel comfortable having this unencrypted.

I found quite a number of queries where users had trouble logging in, but they didn’t really cover my scenario as outlined above.

When I do another encrypted install, is there anything I should check? How would I go about debugging the issue?


Hi hotzenplotz and welcome to the forum :slightly_smiling_face:

When I do another encrypted install, is there anything I should check?

When using full encryption on an install it is important to keep in mind:

  1. a - z are the supported alphabet characters for encryption password.

  2. If you use the number pad when creating the password then you have to use the 1 - 9 keys that are not numberpad to use password at boot. Using numberpad to enter numbers at boot is not recommeded.

This seems to be the most common causes of encryption password not working.

When creating new passwords for login to desktop (KDE, Gnome etc) make sure your keyboard is set to the correct locale setting. For example if you have a german keyboard layout make sure it is set to german. When logging in make sure you are entering user password - not root password - i speak from experience in this one and its embarassing so don’t tell anyone :roll_eyes:

Also, there are known to be problems with Intel - Nvidia hybrid laptop graphics.

Hope this helps.

1 Like

Hi Melways,

Thank you for the response.

My password only uses a-z and no numbers. I’m using the same password for root and user. Since it works for the root account, I believe that the keyboard layout can be ruled out as a cause.

The laptop has an AMD cpu and a nvidia geforce rtx3060 graphic card. Sorry should have mentioned before.

Any other ideas I could check? I find it particularly strange that resetting the user password with passwd doesn’t work…

keyboard-layout can be an issue because in the state of the bootprocess there is only grub handling it and it is defaulting to en_US there so id you may have zy exchanged like german layout it can be an issue per example.
only assuming german from:

1 Like

Har har har, yes you assumed right, however my laptop has an english layout :slight_smile:

I also think this would then affect both, root and user accounts since I’m using the same password.

How does the automatic login work in KDE? Because if this is used then there are no issues until I log out again (or try to use a TTY).

auto login is not asking for password … so it works indeed…
you can also change password on installed system if you can access it from liveiso… simply arch-chroot into it and change the passwords.
It could still be an issue using en_us but using a german keyboard on the hardware side… or you miss to see that livesession before installing is set to DE layout (it does autodetect) … in some cases it also known that the installer can false set keyboard layout if it got a wrong match in cases…

Hi again,

I’m using a US keyboard on the hardware side and the corresponding layout. Also I’m using the same password for root and for user, i.e. exactly the same. I can login as root but cannot, with the same password, login as user somehow…

Changing the password for the user didn’t help either, as discussed above.

Do you use en_US, en_GB, or any other English layouts?

The Australian version:

[user@laptop ~] localectl status
System Locale: LANG=en_AU.UTF-8
VC Keymap: au
X11 Layout: au

But again, I’m typing the same password in for root and user and while it works for root, it doesn’t for user for some reason.

You probably need to check this:

But OP said he uses a US keyboard and US layout.

if root works… passwd username to see if changing userpassword is helping…

1 Like


I did passwd username and it didn’t work.

However, I did download the EOS iso again and reinstalled everything. This time everything works, i.e. it is encrypted and I can login with my username.

All good. Thanks for the moral support of you all :slight_smile:

1 Like

Lots of times people asking for help say things they either don’t know, or aren’t sure of. Terminal outputs don’t lie.

According to your other post - you do not use US layout. But another self-solved thread in the books with zero discernable answer on how to help others. Hurray!

1 Like

Yes, you are right here, sorry!

1 Like

in this case we can turn a blind eye again, after all it’s about the robber Hotzenplotz, he’s a legend!