NetworkManager-wait-online problem

Hi guys

I don’t know what is causing this but lately I sometimes get a black screen, followed by a ‘Failed to sync dbus with environment’ error. It appears to be a problem with NetworkManager as there have been a few reports on other distros but I can’t find how to fix it.
I am using Plasma and it seemed to start after installing nfs-utils to access my NAS via nfs. Sometimes it boots just fine and other times I get that message. A reboot sometimes fixes it and other times I have to reboot quite a few times.
Does anyone know how to fix this?

First question: are you using NFS over wifi?

Second question: what have you looked at so far to make you think it’s related to NetworkManager-wait-online?

1 Like

Hi Jonathon

I’m using NFS via an ethernet connection but the issue has just happened even though I didn’t have the NAS mounted. After the ‘failed to sync dbus with environment’ error, if I look at dmesg, it will say that the NetworkManager-wait-online service failed to start

Have you checked its logs/journal entries? Is there anything interesting or useful in there?

I’ll be honest - I don’t know where to find the logs.

I’ve just done a fresh install as I tried out Opensuse Tumbleweed (nice but I still prefer Endeavour) and so far, it has been fine. I read somewhere that it was something to do with the /etc/nssswitch.config file but I couldn’t get it to work at all before I decided to try Opensuse


sudo journalctl -u NetworkManager-wait-online

Thanks. I never knew about that. I have just installed nfs-utils and mounted my NAS. I’m going to copy a file over and reboot to see if the error happens again.

Ok, now I am completely confused - I have installed Steam, performed numerous reboots and created some snapshots with grub-btrfs and it is still working perfectly. The logs even confirm everything is running fine. Thank you @jonathon for your help, I will mark this as solved - if it happens again, I will start a new topic.
Thank you again :+1:t2:


Hi guys

I believe I have located (and solved) the problem; it appears that I didn’t have the rights to read/write to my mountpoint (/mnt/NAS) which caused NetworkManager to freak out. I chown’d the /mnt/NAS directory to my user and group and this seems to have resolved the problem.

Thanks for your help everyone

1 Like