NetworkManager fails to connect wifi

First of all, I had to install drivers for Realtek RTL8723DU from After that, I saw the wifi device both in rfkill and NetworkManager. It is not blocked according to rfkill. In NetworkManager, I see my wifi. When I choose it, it asks for password. I fill in the password, it is connecting and then it asks for password again and again and again until I press storno.

This device has no port for network cable, so I can install packages only by carrying the source using flash disc and installing them there.

I tried rebooting the router - no effect.
I tried writing [device] wifi.scan-rand-mac-address=no to /etc/NetworkManager/NetworkManager.conf - no effect.
I tried this - no effect.
I tried rebooting, restarting NetworkManager - no effect.

Once I read that this issue can be solved by installing wicd. I have no chance to install an AUR package because I can’t connect to internet. I downloaded and installed (hopefully) all dependencies. I tried compiling from source. I tried the newest version, older version, wicd-patched, I wasn’t able to compile any of them because of syntax errors.

EDIT: I noticed that python stands for python3 and not for python2 so I had to change it. After I did the change, I finally managed to install wicd but it doesn’t do anything. If I run it by sudo wicd --no-daemon, it writes Starting automatic reconnect process 4 times and then it writes Throttling autoconnect until I close it.

EDIT 2: I managed to open the wicd gui. When I chose the network, filled in password and pressed connect, it didn’t connect and threw this message to terminal:

ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/home/ok1asw/Stažené/d1/dbus-python-1.2.16/build/lib.linux-x86_64-2.7/dbus/", line 232, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/share/wicd/gtk/", line 281, in handle_connection_results
    error(self.window, language[results], block=False)
KeyError: dbus.String(u'bad_pass')

I also tried to make the router accessible without password for a short time. That didn’t help either.

any idea?

What does your network show?

inxi -Na

Edit: I just wanted to see if it shows it has a module loaded for it.

Also you might want to try the following package. You can install it with yay.

inxi -Na:

Network:   Device-1: Realtek 802.11n WLAN Adapter type: USB driver: btusb,rtl8723du
           bus-ID: 1-4:6 chip-ID: 0bda:d723 class-ID: e001 serial: 00e04c000001

I already tried the driver rtw88 before I tried the current one and it wasn’t even able to recognise the wifi card. I noticed that many wifi cards are 802.11n but the chip-ID seems to matter. From this site, I concluded that I need RTL8723DU and I found only one driver satisfying this condition.

Could you try this one for usb.

That driver has an error, I just gave them my bugreport.

I also reported this issue to NetworkManager:

The only think i can suggest is look at the Arch wiki and go through the steps to troublshoot. This particular chips seems to be an issue every time i come across it. Not sure if others got it working or replaced it.

Its not only this realtek chip. I ordered a couple of lenovos for work and instead of intel they ship with the proprietary realtek. No wifi of course. I sent them all back last week​:worried:

I am not even sure the issue here is with a bug in Network manager but rather the realtek driver that doesnt play nice with linux kernel and other open source software.

So the best advice I saw online for these is to swap the realtek for intel card. The rest can be hit and miss and instability.

The Realteks are hit and miss. I have the RTL 8822CE on my HP which works as there is a module for that one.


1 Like

Did you play around with other settings? Like CA certificate, security protocol, etc?

The wifi card is embedded inside the laptop. It is a small laptop with detachable screen and it doesn’t have a single screw, so I don’t think that replacing the wifi card is an option. Maybe I can buy an external usb wifi module, can that work? And if yes, can you please give me a tip what to buy and what not? I already know that I should avoid Realtek.

I didn’t play with any other settings.

I tried downgrading NetworkManager to 1.32.4, 1.32.2, 1.10.6 but I wasn’t even able to launch them because of a weird error. It was a different error in each case.

What is the laptop model brand?

UMAX VisionBook 10Wr Tab

So it’s really a tablet.

What desktop did you install on it?

Yes, but I don’t like tablets, so I call it laptop with detachable screen :smiley:
I have xfce desktop.

1 Like

So currently how are you using it if there is no wifi?

I don’t use it, I have a different one and I copy there stuff using an usb flash disc.

I don’t know what to tell you other than i know this particular realtek chip is an issue. It’s difficult as i don’t just have an answer that is going to make it work. Maybe get a usb wireless like this one that will work.

Is tp-link a good brand?

That’s what i use. That one should have the broadcom chip. I have the same one but in a desktop Pci-E card. They aren’t expensive.