Network stopped working

I was using my pc and out of no where the internet stoped working. I tried to figure something but nothing works. I can access the network when i access it from any live usb. But not able to connect from my main boot. So there is nothing wrong with the router. The ifconfig look correct and now I am out of options

Did you try lts kernel? I always install both mainline and lts as fallback.

Here more infos:

No bt now as there is not internet i can’t try it. :slight_smile:

Both wifi and Ethernet?

I don’t have wifi in the pc.

The router shows my device is connected. But in the pc if the ping the router’s ip it does not work. I can ping my ip. So the pc is getting ip address but not being able to connect to the router

Just wondering how old is that USB iso? I think eos switched to another firewall software. Just wondering if that could be the culprit. You could try switch it off to test.

Versus the other driver related problem I suggested above.

Edit: that maybe worth a look about firewall

The usb is pretty old. More than 3 to 4 months. And just to confirm the internet works on usb but not on the main boot.

I generally dont use the computer firewall. Checked the firewalld.service. it is already disabled

Since Apollo release 2022 according to link. In any case you can try to stop the firewall service just to test. If it doesn’t work I suspect could be recent kernel update.

I think it is a kernal problem. Is there any way to install kernal offline or install kernal using a live boot

One way would be to download the package via your live USB, reboot into your system then build locally using pacman. I will let more experienced user chime in.

But the packages can be downloaded here

linux-lts and linux-lts-headers

as usual make backups before making system changes…

Another way is to chroot into your system via live USB. Then install the kernel and update grub mkconfig

Another thing I upgraded the system yestarday. It worked after that. Even I was using it today after rebooting. If its a driver or kernal issue shouldn’t the problem be after i reboot

Note it is good practice to reboot right away when you upgrade a kernel. It may not have picked up all the changes until reboot.

My suggestion would be to go chroot and install lts kernel. (Don’t forget both packages and update grub mkconfig)

Please check:

I don’t know which file system you use, there is another wiki for Btrfs.

New problem when i try to install kernal after chroot

I am not 100% sure that works, but you could try to update the mirrors via the welcome app first. Then try again.


In the linux 5.15.78-1-lts kernal i can not connect to the network device :expressionless:. In /proc/interrupts it does not show the network device.

Strange that it works in the live USB but not on your system, neither main nor lts kernel. I am running out of ideas.

Likely unrelated but you run the new plasma. Just wondering which plasma version did you run before your update?